Bug 479495 - gnome-sessions repeats over and over "You will not receive this message again"
gnome-sessions repeats over and over "You will not receive this message again"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 19:39 EST by Michal Jaegermann
Modified: 2009-06-13 16:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 09:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-09 19:39:57 EST
Description of problem:

Not so long time ago gnome-session started to greet me on every login with the following alert:

=======
Some panel items are no longer available

One or more panel items (also referred to as applets) are no longer available in the GNOME desktop.

These items will now be removed from your configuration:

You will not receive this message again.
=======

Despite this "not receive" above the alert does not show any signs going away. I think that this started to happen when gnome-volume-manager icon vanished from a panel.

The message itself would be not an issue although I would rather had offending items really removed from my configuration at the same moment.  My own attempts to do so, done when the alert in question showed up already a number of times, although did not cause any evident breakage also failed to get rid off that annoyance.

Version-Release number of selected component (if applicable):
gnome-session-2.25.3-1.fc11

How reproducible:
all the time over and over
Comment 1 Michal Jaegermann 2009-01-12 21:03:31 EST
After recent changes, which did NOT include gnome-session, then message displayed in the alert changed to:

===============
Some panel items are no longer available

One or more panel items (also referred to as applets) are no longer available in the GNOME desktop.

These items will now be removed from your configuration:
    • Volume Control
    • Volume Control
    • Volume Control
    • Volume Control
    • Volume Control

You will not receive this message again.
===============

Moreover the message indeed does not show up after it got displayed once.
I am not sure; gnome-media changes are responsible for that?

But 'grep -i volume ~/.xsession-errors' still shows the following:

** (gnome-volume-control-applet:3023): DEBUG: Updating client: index=0 name='ConsoleKit Session /org/freedesktop/ConsoleKit/Session1'
** (gnome-volume-control-applet:3023): DEBUG: Updating client: index=1 name='GNOME Volume Control'
** (gnome-volume-control-applet:3023): DEBUG: Updating sink: index=0 name='alsa_output.pci_1106_3059_sound_card_0_alsa_playback_0' description='VIA 8237 - VIA 8237' map='front-left,front-right'
** (gnome-volume-control-applet:3023): DEBUG: Changing volume for sink: n=2 vol=54067
** (gnome-volume-control-applet:3023): DEBUG: Channel 0 v=54067
** (gnome-volume-control-applet:3023): DEBUG: Channel 1 v=54067
** (gnome-volume-control-applet:3023): DEBUG: Updating source: index=0 name='alsa_output.pci_1106_3059_sound_card_0_alsa_playback_0.monitor' description='Monitor of VIA 8237 - VIA 8237'
** (gnome-volume-control-applet:3023): DEBUG: Updating source: index=1 name='alsa_input.pci_1106_3059_sound_card_0_alsa_capture_0' description='VIA 8237 - VIA 8237'
gnome-session[2822]: WARNING: Application 'gnome-volume-control-applet.desktop' failed to register before timeout
** (gnome-volume-control-applet:3023): DEBUG: Updating client: index=2 name='Native client (UNIX socket client)'
** (gnome-volume-control-applet:3023): DEBUG: Updating client: index=2 name='pactl'

and 'gnome-volume-control-applet' still runs while ***failing to produce
anything on a panel***. That despite that 'grep -irl volume  .[cg]*' in a home
directory comes back only with:

.gnome2/yelp.d/omfindex.xml
.gnome2/yelp.d/manindex.xml
.gnome2/yelp.d/sk-content-list.last
.gstreamer-0.10/registry.x86_64.xml
.gstreamer-0.10/registry.x86_64.bin

Moreover in "Sessions" preferences "Volume Control" is still present and checked in while other setting apparently make it useless.
Comment 2 Ray Strode [halfline] 2009-01-13 09:43:34 EST
The volume control applet got replaced with a notification area icon that's more dynamic and hotplug aware.

I believe the new volume control is called gnome-volume-control-applet and the old one was called mixer_applet2

Matthias mentioned to me yesterday that he fixed the bug you mentioned originally in this report.

I'm going to go ahead and close this one out.
Comment 3 Michal Jaegermann 2009-01-13 13:12:24 EST
> I believe the new volume control is called gnome-volume-control-applet

A stupid question then.  How one is using that one then if its only visible presence in a process list and .xsession-errors?

"Add to panel" features only "deprecated" one and it ignores it.
Comment 4 Ray Strode [halfline] 2009-01-13 13:25:30 EST
The deprecated one shouldn't be showing up in the Add to Panel list.  If it is then it means it wasn't null-appletified properly.

The new one should should show up automatically based on your audio hardware.  If you don't see a volume control (if it isn't working) then would you mind filing a bug against gnome-media?
Comment 5 Michal Jaegermann 2009-01-13 17:16:54 EST
> If you don't see a volume control (if it isn't working) then would you mind
> filing a bug against gnome-media?

It is working but not as an applet.  At least yesterday. :-)

OK, I will check again and file bugs as needed.
Comment 6 Kevin R. Page 2009-06-13 16:30:41 EDT
While I *am* seeing the new volume control in the notification error since upgrading to F11, I'm getting also getting the message below *every time I log in*. 

Bug #452913 is similar.
--

Some panel items are no longer available

One or more panel items (also referred to as applets) are no longer available in the GNOME desktop.

These items will now be removed from your configuration:
    • Volume Control

You will not receive this message again.

Note You need to log in before you can comment on or make changes to this bug.