Bug 479520 - Black screen, error message about AGP for rv280
Black screen, error message about AGP for rv280
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 11:06 EST by Bruno Wolff III
Modified: 2009-04-18 03:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-18 03:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from broken session (53.00 KB, text/plain)
2009-01-10 11:06 EST, Bruno Wolff III
no flags Details
Xorg.0.log from working session on F10 (104.42 KB, text/plain)
2009-01-10 11:08 EST, Bruno Wolff III
no flags Details
Sorted output from lsmod for broken session on f11 (2.49 KB, text/plain)
2009-01-10 11:10 EST, Bruno Wolff III
no flags Details
Sorted lsmod output from working session on f10 (2.85 KB, text/plain)
2009-01-10 11:11 EST, Bruno Wolff III
no flags Details
xorg.conf file (1.00 KB, text/plain)
2009-01-10 11:13 EST, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-01-10 11:06:47 EST
Created attachment 328626 [details]
Xorg.0.log from broken session

Description of problem:
Currently in F11 I am getting a black screen for X. The Xorg.0.log file has a complaint about an agp related kernel module. I don't see that module loaded for F10, but maybe it is built in to the kernel. It was working about a week ago and stopped working after a kernel change, so it might really be a kernel bug.
vt's work OK.
As usual I have to rebuild xorg-x11-drv-ati to work around the driver not liking EDID not being done properly by my monitor. Without this the screen is black because of no signal, with the change I am currently getting a signal, but the screen is still black.
I'll be attaching various files from my F10 and F11 instances. Things are working in F10 currently.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.10.0-1.fc11.i386
kernel-2.6.29-0.24.rc0.git13.fc11.i686

How reproducible:
100%

Steps to Reproduce:
1. Boot into F11
2.
3.
  
Actual results:
Black screen for X display

Expected results:
Normal session information appearing on display

Additional info:
Comment 1 Bruno Wolff III 2009-01-10 11:08:56 EST
Created attachment 328627 [details]
Xorg.0.log from working session on F10
Comment 2 Bruno Wolff III 2009-01-10 11:10:05 EST
Created attachment 328628 [details]
Sorted output from lsmod for broken session on f11
Comment 3 Bruno Wolff III 2009-01-10 11:11:14 EST
Created attachment 328629 [details]
Sorted lsmod output from working session on f10
Comment 4 Bruno Wolff III 2009-01-10 11:13:02 EST
Created attachment 328630 [details]
xorg.conf file

I double checked to confirm that the xorg.conf files were identical for F11 and F10. So I am only attaching one of them.
Comment 5 Bruno Wolff III 2009-02-01 23:57:42 EST
Note that I am able to get the radeon (and vesa driver for F11) working by passing nomodeset using 2.6.29-0.6.rc3.fc10.i686 or 2.6.29-0.73.rc3.git2.fc11.i686.
Comment 6 Bruno Wolff III 2009-02-04 23:26:47 EST
In rawhide things have now reversed. With kernel 2.6.29-0.78.rc3.git5.fc11.i686 I now must NOT use the nomodeset parameter in order for things to work with the radeon driver. (I didn't retest the vesa driver.)
Comment 7 Bruno Wolff III 2009-04-18 03:16:37 EDT
I am still having modeset problems with this card, but I don't think it is the same problem as this was so I am going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.