Bug 479531 - emacs-git overrides vc-git.el provided by emacs with an inferior version
emacs-git overrides vc-git.el provided by emacs with an inferior version
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 13:51 EST by dann
Modified: 2013-01-10 05:29 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.6.0.6-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:44:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann 2009-01-10 13:51:16 EST
Description of problem:
Support for git in emacs-22 is provided by /usr/share/emacs/22.2/lisp/vc-git.elc,
but the emacs-git package also provides a vc-git.elc file: 
/usr/share/emacs/site-lisp/vc-git.elc.
AND emacs-git sets things up in such a way that /usr/share/emacs/site-lisp/vc-git.elc is actually used instead of /usr/share/emacs/22.2/lisp/vc-git.elc.

The problem is that /usr/share/emacs/site-lisp/vc-git.elc as provided by emacs-git is older and has less features. 

See below how to see some missing features of the emacs-git provided vc-git.elc

It does not seem like a good idea for emacs-git to replace a part of Emacs with an inferior, older version...

Version-Release number of selected component (if applicable):
emacs-git-1.6.0.6-1.fc10.i386

How reproducible:


Steps to Reproduce:
1. emacs -Q  
2. C-x C-f SOME_FILE_MANAGED_BY_GIT RET
3. C-x v l
4. M-x load-file /usr/share/emacs/22.2/lisp/vc-git.elc RET
5. C-x C-f SOME_OTHER_FILE_MANAGED_BY_GIT RET
6. C-x v l

  
Actual results:
After step 3: you will get a log buffer, note that it does not have syntax highlighing.
After step 6: you will get a log buffer with syntax highlighting

Expected results:


Additional info:
The git-blame.el file, also included in emacs-git is not very useful, it provides a small, less integrated part of the functionality already available in vc-git.elc when using the C-x v g command
Comment 1 Todd Zullinger 2009-01-11 22:08:28 EST
Looking at git.git, it seems like contrib/emacs is still seeing some activity (most recent being November 7, 2008).  Is vc-git.el intended to make the emacs-git package obsolete or are they just different implementations?

Should we just drop the emacs-git package from the Fedora branches or is it still useful in any ways?  If it is still useful, can we install the files in emacs-git in a way that doesn't supersede the files included in emacs-common?  (Are any of the git maintainers emacs users?)

Of course, the emacs-git package isn't installed by default and shouldn't be required, so if it just isn't as nice as the built-in emacs support, users don't have to install it.  Right?
Comment 2 dann 2009-01-14 02:24:25 EST
(In reply to comment #1)
> Looking at git.git, it seems like contrib/emacs is still seeing some activity
> (most recent being November 7, 2008).  Is vc-git.el intended to make the
> emacs-git package obsolete or are they just different implementations?

They were the same implementations at some point, but the one included in emacs has has some additional features added...

> Should we just drop the emacs-git package from the Fedora branches or is it
> still useful in any ways?  If it is still useful, can we install the files in
> emacs-git in a way that doesn't supersede the files included in emacs-common? 

git.el is still useful.  
git-blame.el is not very useful, better functionality is provided by the vc.el + vc-git.el
vc-git.el is actively bad.


> Of course, the emacs-git package isn't installed by default and shouldn't be
> required, so if it just isn't as nice as the built-in emacs support, users
> don't have to install it.  Right?
Comment 3 Fedora Update System 2009-03-02 15:10:49 EST
git-1.6.0.6-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/git-1.6.0.6-3.fc10
Comment 4 Fedora Update System 2009-03-03 10:26:47 EST
git-1.6.0.6-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update git'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2258
Comment 5 Fedora Update System 2009-03-16 15:44:42 EDT
git-1.6.0.6-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.