Bug 479574 - xgettext does not know the language of anaconda (patch included)
xgettext does not know the language of anaconda (patch included)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 11:06 EST by Muayyad Alsadi
Modified: 2009-01-12 15:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 10:48:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix generating anaconda.pot (-p0 patch) (1.02 KB, patch)
2009-01-11 11:06 EST, Muayyad Alsadi
no flags Details | Diff

  None (edit)
Description Muayyad Alsadi 2009-01-11 11:06:55 EST
Created attachment 328663 [details]
fix generating anaconda.pot (-p0 patch)

Description of problem:
xgettext does not know the language of anaconda because it has no extension 

Version-Release number of selected component (if applicable):
anaconda-11.4.1.63-1

How reproducible:
always

Steps to Reproduce:
1. cd po
2. make anaconda.pot
  
Actual results:
xgettext complains about unclosed quotes

Expected results:
no errors

Additional info:
patch is included
Comment 1 Chris Lumens 2009-01-12 10:48:19 EST
Actually we now have to run xgettext twice - once for the python files and once for the C files.  It doesn't look like you can pass --lang=python <some files> --lang=c <other files>.  With that one modification, I'll apply this.  Thanks for the patch.
Comment 2 Muayyad Alsadi 2009-01-12 12:04:14 EST
yes your changes are better

one last thing, the man/info page said it should be --language not the short --lang
I'm not sure if --lang is correct
Comment 3 Muayyad Alsadi 2009-01-12 15:32:59 EST
I noticed a warning in the second xgettext saying it does not like charset=CHARSET so should we put

sed -i -e 's!^"Content-Type: text/plain; charset=CHARSET!"Content-Type: text/plain; charset=UTF-8!' $(NLSPACKAGE).po

between them ?

Note You need to log in before you can comment on or make changes to this bug.