Bug 479575 - (itk) Feature request: itk mpm for apache
Feature request: itk mpm for apache
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
http://mpm-itk.sesse.net/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 11:27 EST by Lev Shamardin
Modified: 2009-01-13 07:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 03:56:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the httpd-2.2.10-2 spec to include itk mpm (766 bytes, patch)
2009-01-11 11:27 EST, Lev Shamardin
no flags Details | Diff

  None (edit)
Description Lev Shamardin 2009-01-11 11:27:55 EST
Created attachment 328667 [details]
patch for the httpd-2.2.10-2 spec to include itk mpm

Description of problem:
httpd package shipped with fedora can be extended with a very useful MPM for Apache, that is ITK MPM (see URL link)

Version-Release number of selected component (if applicable):
httpd-2.2.10-2.i386

I attach a patch to the spec file which adds the ITK MPM to this ticket. It would be very nice to see ITK MPM in Fedora package, please consider adding it.

The proposed patch for spec requires this file to be placed in SOURCES: http://mpm-itk.sesse.net/apache2.2-mpm-itk-20080727-00.patch
Comment 1 Pavel Alexeev 2009-01-12 02:21:27 EST
I'm for long time use Apache-itk on servers and have compleate srpm (patch for perchild rpm also included) for that in my repository - http://hubbitus.net.ru/rpm/Fedora9/httpd/httpd-2.2.9-1.fc9.Hu.0.src.rpm. Please see, if it is interesting.
Comment 2 Joe Orton 2009-01-12 03:56:07 EST
We're not shipping patched-in MPMs - the authors need to get this upstream if they want it in Fedora.
Comment 3 Pavel Alexeev 2009-01-12 04:00:42 EST
Why you can't shipping alternative additional MPM as alternative?

Can we build it as subpackage like httpd-itk?
Comment 4 Joe Orton 2009-01-12 04:06:22 EST
Because an MPM is a major piece of functionality and as such it needs to get reviewed and accepted upstream.  Fedora is not a substitute for upstream.
Comment 5 Pavel Alexeev 2009-01-12 05:56:30 EST
Fedora is a collection of free software comes with no warranty for any purpose. So, any free people can make decision to use or do not use this MPM! And this is very-very usefully if they can use it from RPM instead of directly building from source. Furthermore, original MPM patch (http://mpm-itk.sesse.net/) also developed by another upstream developer and supported for long time. I do not see any problem with it. The only one problem here is what Fedora is binary Linux distribution and we can't provide patch in separate rpm-package, so, we need build it. But I also fully agreed with Steinar H. Gunderson to do NOT fork apache for this purpose. So, patch seems more friendly distribution for them in this case. As total: we have 2 upstream developers, and do not try substitute any of them in Fedora we only needed build package(es) from several sources from various developers.

P.S. May be I can help you to co-maintain this MPM? As mentioned above this distributed as patch and a think it is very bad idea to post separately on review new package with original apache source for that.
Comment 6 Joe Orton 2009-01-13 07:38:40 EST
Well, patching in a new MPM is a major fork of httpd in my opinion both as Fedora maintainer and as an upstream developer.  If the MPM's authors think it is worthy of inclusion in upstream httpd then they should work with upstream to make that happen.  There is no more to discuss here.

Note You need to log in before you can comment on or make changes to this bug.