Bug 479577 - pure-ftpd breaks system-config-services
pure-ftpd breaks system-config-services
Status: CLOSED DUPLICATE of bug 467871
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 11:40 EST by Jeffery Johnson
Modified: 2009-02-17 06:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 06:34:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffery Johnson 2009-01-11 11:40:27 EST
Description of problem:
After thorough testing I have found that the app pure-ftpd breaks system-config-services.  When pure-ftpd is installed, system-config-services hangs while loading services, and remains grey and indicates that the program is busy ( via mouse pointer icon ). The app never recovers.

Version-Release number of selected component (if applicable):

Name       : pure-ftpd
Arch       : i386
Version    : 1.0.21
Release    : 16.fc10

Name       : system-config-services
Arch       : noarch
Version    : 0.99.28
Release    : 3.fc10


How reproducible:

I duplicated this on 2 computers, a HP Pavilion dv4000 and a Dell Optiplex 745.

Steps to Reproduce:
1. Install Fedora 10 with pure-ftpd
2. Attempt to run system-config-services (should hang)
3. Remove pure-ftpd
4. Attempt to run system-config-services (should run )

The actual steps to locate the problem app were much more complicated and involved installing a generic installation of Fedora 10 without optional pakages. Then, installing apps a few at a time, restarting, and testing system-config-services.  This was repeated until system-config-services broke.  Then, once broken, take the list of apps that was installed that broke system-config-services and remove each app one at a time, and test system-config-services until functioning again.  Once the culprit app was found, I installed all other apps, restarted, and tested syster-config-services again.. and it worked without error.  I again installed pure-ftpd, restarted, and system-config-services was broken again.  I removed pure-ftpd again, and system-config-services worked again.

 
Actual results:
pure-ftpd breaks system-config-services on every test on multiple systems

Expected results:
pure-ftpd breaks system-config-services


Additional info:
Comment 1 Julian Weißgerber 2009-01-16 05:40:20 EST
You can workaround this bug by launching system-config-services using sudo, then wait for the python debug message to appear, and press ctrl+c. The program will then work normally it seems.
Comment 2 Nils Philippsen 2009-02-17 06:34:43 EST

*** This bug has been marked as a duplicate of bug 467871 ***

Note You need to log in before you can comment on or make changes to this bug.