Bug 479592 - no font metrics in fc10
no font metrics in fc10
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 15:41 EST by Artem Zolochevskiy
Modified: 2010-11-23 23:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.40
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 20:24:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Artem Zolochevskiy 2009-01-11 15:41:15 EST
I have tried to build russian pdf book with publican (0.39-0.fc10). Result is unreadable because of missed font metrics in fop/font-metrics/ dir. fop.xconf file also contains nothing in <fonts> section.

For proper building I see 2 ways:
1. '.f10' section in fop-fonts source file
2. using auto-detect feature in <fonts> section in fop.xconf
In the latter case we need to use proper font names. For example in pdf.xsl:
s/LiberationSans/Liberation Sans/

--
Sorry for my bad English :(
Comment 1 Jeff Fearn 2009-01-12 22:33:20 EST
I'm working on this atm, works on RHEL 5 and F10 using auto-detect except the two Chinese languages break on F10. More testing required.
Comment 2 Jeff Fearn 2009-01-15 20:24:35 EST
Switched to auto-dectect.
Comment 3 Fedora Update System 2009-01-16 02:40:43 EST
publican-fedora-0.17-0.fc10,publican-0.40-0.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/publican-fedora-0.17-0.fc10,publican-0.40-0.fc10
Comment 4 Fedora Update System 2009-01-16 02:43:14 EST
publican-fedora-0.17-0.fc9,publican-0.40-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-fedora-0.17-0.fc9,publican-0.40-0.fc9
Comment 5 Fedora Update System 2009-01-21 16:32:58 EST
publican-fedora-0.17-0.fc10, publican-0.40-0.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.