Bug 479627 - Unable to retrieve MSN Address Book
Unable to retrieve MSN Address Book
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 03:40 EST by Jóhann B. Guðmundsson
Modified: 2009-01-16 19:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 19:06:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pidgin --debug (99.57 KB, text/plain)
2009-01-12 03:40 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2009-01-12 03:40:47 EST
Created attachment 328711 [details]
pidgin --debug

Description of problem:

Unable to retrieve MSN Address Book 

Wondering if MSN has blocked the ApplicationId that is used by msnp$version.

Version-Release number of selected component (if applicable):

pidgin-2.5.3-1.fc9.x86_64

How reproducible:

Try to connect to an msn account

Steps to Reproduce:
1. Setup an msn account 
2. Try to connect..
3.
  
Actual results:

Unable to retrieve MSN Address Book

Expected results:

Being able to retrieve the MSN Address Book.. 

Additional info:
Comment 1 Jóhann B. Guðmundsson 2009-01-12 03:44:25 EST
Successful login to the msn account via http://login.live.com/
Comment 2 Jean-Francois Saucier 2009-01-12 09:37:30 EST
I can confirm this bug for Fedora 10 as well : pidgin-2.5.3-1.fc10.i386


Upstream know the bug too : http://www.nabble.com/-8080%3A-Unable-to-retrieve-MSN-address-book-td21407542.html

There is no clear solution for the moment it seems.
Comment 3 James Ettle 2009-01-12 09:53:02 EST
The workaround I'm using is to get libpurple-devel and pidgin-devel, and build the msn-pecan plugin from http://code.google.com/p/msn-pecan/ .
Comment 4 Jóhann B. Guðmundsson 2009-01-12 12:12:20 EST
Well the plugin seems to be stuck in paperwork #451298..

Perhaps Felipe should step in here and make this happen.. 

Anyway you can build your own package of the plugin and make it available to your
users simply cd into your SOURCE directory then do 

wget -c http://msn-pecan.googlecode.com/files/msn-pecan-0.0.17.tar.bz2 

cd into your SPEC directory and do  

wget -c http://www.linuxed.net/~madko/fedora/pidgin-msn-pecan.spec  

open up your favourite text editor and change the version ( second line ) from 0.0.13 to 0.0.17 then run 

rpmbuild -ba pidgin-msn-pecan.spec 

and voila you have rpm package which you can install with rpm -ihv <package> 

Then you can just point your users to the package and ask them to change their
msn account from being a msn account to be a WLM..
Comment 5 James Ettle 2009-01-12 12:40:44 EST
This affects Adium, another purple-based client. http://adiumx.com/blog/2009/01/msn-rejecting-adium-132-connections/ has more information --- from what I understand, this is an MSNP15 issue but msn-pecan uses MSNP12, which happens to still work. Anyway, the Pidgin team are working on the fix: see http://theflamingbanker.blogspot.com/2009/01/msn-issues.html .
Comment 6 James Ettle 2009-01-12 15:16:52 EST
Yay! Fixed for me in pidgin/libpurple-2.5.4-1.fc10.x86_64 from Koji.
Comment 7 Stu Tomlinson 2009-01-12 15:23:51 EST
MSN appear to have reverted at least part of what changed so it is likely Pidgin 2.5.3 will work again for some people.
Comment 8 Jóhann B. Guðmundsson 2009-01-13 01:37:21 EST
Fixed for me in 4-1.. I recommend this be pushed to updates-testing as soon as 
possible..
Comment 9 Warren Togami 2009-01-16 19:06:41 EST
Only a temporary server problem, closing.

Note You need to log in before you can comment on or make changes to this bug.