Bug 479649 - Two Wine menus present
Summary: Two Wine menus present
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 495953
TreeView+ depends on / blocked
 
Reported: 2009-01-12 11:14 UTC by Julian Sikorski
Modified: 2009-09-11 23:30 UTC (History)
2 users (show)

Fixed In Version: 1.1.29-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-11 23:30:07 UTC


Attachments (Terms of Use)

Description Julian Sikorski 2009-01-12 11:14:03 UTC
Description of problem:
Older wine versions (prior to 1.1.10, I guess) created the menu entries (~/config/menus/applications-merged/*.menu) containing <Name>Wine</Name> entry, wine-desktop package is also done in this manner. I have noticed, though, that as of 1.1.10 the said entry defaults to <Name>wine-wine</Name>, resulting in two Wine menus present.

Version-Release number of selected component (if applicable):
1.1.10-1.fc10

How reproducible:
always

Steps to Reproduce:
1. Install wine-desktop
2. Install a Windows program which puts entries into the start menu
3. Have a look at your gnome menu
  
Actual results:
There are two wine menus: one with entries from wine-desktop, and one with the ones that came with the Windows software

Expected results:
There is only one Wine menu

Comment 1 Dawid Zamirski 2009-03-03 21:26:11 UTC
Same happened to me, but only after I tried to edit them with the menu editor:
* right click on Applications
* choose 'Edit Menus'
* change some entry in Wine

After messing with the Wine sub-menu (I actually didn't change anything over there - I just played with it to get it better organized, but after failing to do so, I put it back the way it originally was), I ended up with two Wine entries one of which has the wine-* prefix. Newly installed Win32 application's entries appear in the good one - the one with no wine-* prefix.

Comment 2 Julian Sikorski 2009-06-21 10:40:36 UTC
The new entries can be ported back to the old format by running
$ sed -i "s#<Name>wine-wine</Name>#<Name>Wine</Name>#" ~/.config/menus/applications-merged/wine-*.menu
But the proper fix would be to port the desktop entries in the wine-desktop package to the new format.

Comment 3 Fedora Update System 2009-06-24 14:20:28 UTC
wine-1.1.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wine-1.1.24-2.fc10

Comment 4 Fedora Update System 2009-06-24 14:21:50 UTC
wine-1.1.24-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wine-1.1.24-2.fc11

Comment 5 Julian Sikorski 2009-06-24 16:25:45 UTC
I just had a quick look at the cvs and the updated wine.menu did not make it to F-11 nor F-10. Was that intended? If so, please remove this bug from the update description and just close it as rawhide.

Comment 6 Fedora Update System 2009-06-24 17:21:26 UTC
wine-1.1.24-2.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wine-1.1.24-2.fc10.1

Comment 7 Fedora Update System 2009-06-24 17:23:34 UTC
wine-1.1.24-2.fc11.1 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/wine-1.1.24-2.fc11.1

Comment 8 Fedora Update System 2009-06-27 02:50:38 UTC
wine-1.1.24-2.fc10.1 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6996

Comment 9 Fedora Update System 2009-06-27 03:00:31 UTC
wine-1.1.24-2.fc11.1 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7043

Comment 10 Fedora Update System 2009-07-14 20:51:18 UTC
wine-1.1.25-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/wine-1.1.25-1.fc10

Comment 11 Fedora Update System 2009-07-19 10:22:10 UTC
wine-1.1.25-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7753

Comment 12 Dawid Zamirski 2009-07-25 20:33:16 UTC
This problem is fixed on my machine. I'm currently running: wine-1.1.24-2.fc11.1.i586

Comment 13 Fedora Update System 2009-09-01 18:06:30 UTC
wine-1.1.28-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9220

Comment 14 Fedora Update System 2009-09-04 04:08:18 UTC
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9304

Comment 15 Fedora Update System 2009-09-11 23:29:19 UTC
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.