Bug 479658 - OpenOffice 3 fails to open/save/lock files on SMB shares
OpenOffice 3 fails to open/save/lock files on SMB shares
Status: CLOSED DUPLICATE of bug 479199
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 06:44 EST by Lorenzo Scano
Modified: 2009-01-12 06:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 06:51:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lorenzo Scano 2009-01-12 06:44:02 EST
Description of problem:
when accessing files on a SMB share the following happens, making OOo unusable:

- when opening a file, it is opened read-only and cannot be saved;
- when the file is closed the hidden lock file (.~lock.FILENAME#) ISN'T removed as it should;
- when the file is re-opened, it opens read-write despite the fact that a lock file is there;
- when then changes are made and a save is tried, it complains that it cannot be done due to some permission failure (this is false since write access on the share is granted and every other program is not having troubles).

Version-Release number of selected component (if applicable):
3.0.0-9.10.fc10

How reproducible:
any OOo app acting on files on a SMB share

Steps to Reproduce:
1. open nautilus to a SMB share folder containing some OOo document;
2. click on document icon;
3. try to modify-save document.
  
Actual results:
document is first opened ro then, next time rw but no changes can be made (see above).

Expected results:
document should be accessed rw and changes should be saved on disk.

Additional info:
the problem occurs with community OOo version too (i386 and x86_64); the issue is probably somewhere upstream. I found out that many installations suffer from similar problems (see: http://user.services.openoffice.org/en/forum/viewtopic.php?f=6&t=11255&start=0&st=0&sk=t&sd=a) but suggested workarounds had no effect.
Comment 1 Caolan McNamara 2009-01-12 06:51:05 EST

*** This bug has been marked as a duplicate of bug 479199 ***

Note You need to log in before you can comment on or make changes to this bug.