Bug 479673 - Ugly appearance of windows and wrong calculation of character width's by eclipse
Ugly appearance of windows and wrong calculation of character width's by eclipse
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 08:05 EST by Hedayat Vatankhah
Modified: 2009-05-15 08:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 08:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An image which shows what happens in Eclipse in fa locale (63.11 KB, image/png)
2009-05-08 10:11 EDT, Hedayat Vatankhah
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 276455 None None None Never

  None (edit)
Description Hedayat Vatankhah 2009-01-12 08:05:25 EST
Description of problem:
In Fedora 10, when I set the system locale to fa_IR (Persian Language) and log in to gnome many things are larger which results in an ugly desktop. Gnome panel's minimum height which is 24 in en_US locale is 29 in fa_IS locale. Windows' title bars are also are larger (more height). The worst thing is that these sizes do not depend on the selected font! 
Totally, the desktop is uglier in fa_IR locale. 
Things are still not that bad till now, but in Eclipse when you enable "show print margin" option in its text editor settings, the line which is intended to show the 80 character margin appears in the middle of the editor, around character 50. In en_US locale, it appears in the correct position.

How reproducible:
Always

Steps to Reproduce:
1.In the gdm login screen, select Persian language and login
2.You can see that gnome applet is larger, and larger icons appear in it as a result
3.Run eclipse and enable "show print margin", in its text editor preferences.
4. The print margin in eclipse appears in the middle of the text editor area, which is around character 50, while it should appear at the end of 80th character.
  
Expected results:
Normal window sizes and correct estimation of print margin in eclipse text editor.
Comment 1 Hedayat Vatankhah 2009-04-09 08:05:15 EDT
The problem still exists in Fedora 11 Beta (Gnome LiveCD)
Comment 2 Hedayat Vatankhah 2009-05-08 10:11:31 EDT
Created attachment 343092 [details]
An image which shows what happens in Eclipse in fa locale
Comment 3 Andrew Overholt 2009-05-08 13:53:13 EDT
Hedayat, have you tried with a download from eclipse.org?  If you can, grab one of the builds from here for your architecture:

http://download.eclipse.org/eclipse/downloads/drops/S-3.5M7-200904302300/index.php

Then, do something like:

tar zxf eclipse-*.tar.gz
cd eclipse
./eclipse -data /tmp/testFontStuff

and see if you can reproduce there.  We don't do any patching to our Eclipse packages in this area so I suspect it is an upstream thing.
Comment 4 Hedayat Vatankhah 2009-05-14 16:35:32 EDT
Yes, the same problem exists with the latest eclipse M7 build. I don't know why the line appears in the wrong position, but it worked fine in Fedora 9. I had the problem started with Fedora 10, with the same eclipse version as what I used in Fedora 9.
Comment 5 Andrew Overholt 2009-05-14 16:49:32 EDT
Thanks for trying with upstream.  To ensure the highest chance of this getting fixed, it will be best to file a bug at bugs.eclipse.org.  If you do so, please add a reference to it on this bug under "External Bugs" above.
Comment 6 Andrew Overholt 2009-05-15 08:28:40 EDT
Thanks, Hedayat.  Closing as upstream.

Note You need to log in before you can comment on or make changes to this bug.