Bug 479685 - fop fails with SEVERE: Couldn't find hyphenation pattern en (fop-hyph must be packaged)
fop fails with SEVERE: Couldn't find hyphenation pattern en (fop-hyph must be...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fop (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 09:27 EST by Murray Cumming
Modified: 2009-02-10 00:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 00:07:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 310882 None None None Never

  None (edit)
Description Murray Cumming 2009-01-12 09:27:18 EST
On Fedora 10, when trying to generate a PDF with fop, it fails like so, presumably because fop-hyph is not packaged. It was previously part of fop itself, as pointed out in this similar Ubuntu bug:
https://bugs.launchpad.net/ubuntu/+source/fop/+bug/310882

This is the full error:
Jan 6, 2009 4:26:56 PM org.apache.fop.hyphenation.Hyphenator getHyphenationTree
SEVERE: Couldn't find hyphenation pattern en
Comment 1 Ioana Ivan 2009-02-10 00:07:11 EST
The hyphenation patterns can't be included in the fop package due to licensing issues (http://xmlgraphics.apache.org/fop/0.95/hyphenation.html#license-issues). They need to be installed separately (see instructions at http://offo.sourceforge.net/hyphenation/fop-stable/installation.html)

Note You need to log in before you can comment on or make changes to this bug.