Bug 479693 - please update cyrus-imapd to latest upstream 2.3.13
please update cyrus-imapd to latest upstream 2.3.13
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 09:57 EST by Matt Bernstein
Modified: 2009-02-07 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-07 17:23:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Bernstein 2009-01-12 09:57:28 EST
Release notes include "Several skiplist transaction bugfixes", at least one of which seems to break my replication set-up.

Happy to test koji builds, or even an SRPM.
Comment 1 Michal Hlavinka 2009-01-13 14:34:19 EST
building...
Comment 2 Fedora Update System 2009-01-13 14:45:03 EST
cyrus-imapd-2.3.13-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.13-1.fc10
Comment 3 Fedora Update System 2009-01-14 22:04:04 EST
cyrus-imapd-2.3.13-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-imapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0504
Comment 4 Javier Alejandro Castro 2009-01-19 12:09:29 EST
I installed the update, and got those lines on the maillog

Jan 19 13:31:39 mail master[6941]: about to exec /usr/lib/cyrus-imapd/imapd
Jan 19 13:31:39 mail master[6942]: about to exec /usr/lib/cyrus-imapd/imapd
Jan 19 13:31:39 mail pop3[6842]: Fatal error: Internal error: assertion failed: libcyr_cfg.c: 199: cyrus_options[opt].opt == opt
Jan 19 13:31:39 mail imap[6941]: Fatal error: Internal error: assertion failed: libcyr_cfg.c: 199: cyrus_options[opt].opt == opt
Jan 19 13:31:39 mail imaps[6942]: Fatal error: Internal error: assertion failed: libcyr_cfg.c: 199: cyrus_options[opt].opt == opt

Pop3 does not respond, neither imap, etc. Please fix!
Comment 5 Michal Hlavinka 2009-01-20 04:25:16 EST
(In reply to comment #4)
> I installed the update, and got those lines on the maillog
> 
> Jan 19 13:31:39 mail master[6941]: about to exec /usr/lib/cyrus-imapd/imapd
> Jan 19 13:31:39 mail master[6942]: about to exec /usr/lib/cyrus-imapd/imapd
> Jan 19 13:31:39 mail pop3[6842]: Fatal error: Internal error: assertion failed:
> libcyr_cfg.c: 199: cyrus_options[opt].opt == opt
> Jan 19 13:31:39 mail imap[6941]: Fatal error: Internal error: assertion failed:
> libcyr_cfg.c: 199: cyrus_options[opt].opt == opt
> Jan 19 13:31:39 mail imaps[6942]: Fatal error: Internal error: assertion
> failed: libcyr_cfg.c: 199: cyrus_options[opt].opt == opt
> 
> Pop3 does not respond, neither imap, etc. Please fix!

There was only small hope new version would just work... I'll look at this
Comment 6 Michal Hlavinka 2009-01-21 09:53:28 EST
fixed (I hope there is no other problem) and building 2.3.13-2
Comment 7 Fedora Update System 2009-01-21 10:12:07 EST
cyrus-imapd-2.3.13-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cyrus-imapd-2.3.13-2.fc10
Comment 8 Fedora Update System 2009-01-21 16:26:38 EST
cyrus-imapd-2.3.13-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-imapd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0712
Comment 9 Matt Bernstein 2009-01-25 16:50:39 EST
bodhi doesn't like my comments right now (HTTP 500..).

Anyway, at least sync_server works with this package--thanks.

Was it a compiler interaction? Will the SRPM build OK on older distributions?
Comment 10 Michal Hlavinka 2009-01-26 05:29:23 EST
there was problem with position dependent source code - patch included something inside enum. It resulted in different numbers (order) than it was last time (and expected by other functions).

srpm will work
Comment 11 Fedora Update System 2009-02-07 17:23:28 EST
cyrus-imapd-2.3.13-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.