Bug 479707 - anaconda loader crashes when configuring a network interface
anaconda loader crashes when configuring a network interface
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Alpha/F11AlphaBlocker
  Show dependency treegraph
 
Reported: 2009-01-12 11:31 EST by Mark McLoughlin
Modified: 2009-01-16 06:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 06:51:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-01-12 11:31:37 EST
With 2009-01-12 rawhide on x86_64 machine

Steps:

  1) PXE boot w/ cmdline:

       console=ttyS0,115200n81 lang=en_US.UTF-8 keymap=uk vnc method=http://..

  2) Network config screen appears, select DHCP

  3) After ~40s, fails with:

       Network Error

       There was an error configuring your network interface.

       Retry

  4) loader crashes with:

/sbin/loader(loaderSegvHandler+0x7e)[0x40965e]
/lib64/libc.so.6[0x7f254a7a7fe0]
/sbin/loader(main+0x19ca)[0x40b8ba]
/lib64/libc.so.6(__libc_start_main+0xe6)[0x7f254a7935c6]
/sbin/loader[0x4078e9]
install exited abnormally [1/1]
Comment 1 Mark McLoughlin 2009-01-16 06:51:59 EST
Seems to be fixed by:

* Wed Jan 14 2009 David Cantrell <dcantrell@redhat.com> - 11.5.0.8-1
- Fix D-Bus usage in get_connection in loader (jkeating)

Tested with 20090116 rawhide

Note You need to log in before you can comment on or make changes to this bug.