Bug 479721 - Deselecting 'display window contents while resizing' causes display to blank
Deselecting 'display window contents while resizing' causes display to blank
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 12:32 EST by Dan Davis
Modified: 2009-12-18 02:35 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:35:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (39.84 KB, text/plain)
2009-01-12 17:52 EST, Dan Davis
no flags Details

  None (edit)
Description Dan Davis 2009-01-12 12:32:18 EST
Description of problem:
On a fresh install of Fedora 10 x86_64 with KDE, I deselected the 'display window contents while resizing' option under system settings and applied.
The display changed immediately to a solid white display except for the outline of the window and the mouse pointer.  The mouse pointer would still move around the screen, and changed to the resize pointer over the window border.

After using ctrl-alt-backspace to kill X and logging back in, the kde splash screen displays and then the display goes all black except for the mouse pointer.  In this state, KDE is completely unusable.

Version-Release number of selected component (if applicable):
4.1.3-7

How reproducible:
don't know yet

Steps to Reproduce:
1.  In KDE, Go to system config --> window settings (?)
2.  Deselect the "display window contents while resizing" option
3.  Apply
  
Actual results:
Screen turns solid white.

Expected results:
System functions normally, and while resizing a window only the border of the window is displayed.


Additional info:
If anyone can tell me how to change this option back from a console I can try to reproduce it, until then, KDE is unusable on this system, as it only displays a blank screen.
Comment 1 Kevin Kofler 2009-01-12 12:39:02 EST
What graphics hardware and driver?
Comment 2 Dan Davis 2009-01-12 12:52:29 EST
NV driver on a Nvidia Geforce 7300 GS
Comment 3 Rex Dieter 2009-01-12 12:54:40 EST
workaround,
Look in ~/.kde/share/config/kwinrc
look for
MoveMode=
and remove that line

In the meantime, looks, acts, smells like a driver bug, reassigning.
Comment 4 Matěj Cepl 2009-01-12 13:10:04 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Dan Davis 2009-01-12 17:52:58 EST
Created attachment 328797 [details]
Xorg log file
Comment 6 Dan Davis 2009-01-12 18:01:22 EST
This is now more strange.  I tried changing the ResizeMode line in the kwinrc file to Opaque, and tried deleting the MoveMode and ResizeMode lines from the file, none of which worked.  However, compositing was set to enabled=true, and setting that back to enabled=false fixed the problem.

So now my bug is that compositing was enabled for some reason, without the 10 second did this work button, when I changed the option to display content in resizing windows in the window behavior gui.  

I can not reproduce this effect, and I know compositing was not turned on before I changed resizing behavior (because the graphics don't work with compositing enabled).  Intentionally turning compositing on does immediately reproduce the effect, but correctly reverts in 10 seconds.
Comment 7 Bug Zapper 2009-11-18 05:44:23 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-12-18 02:35:32 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.