Bug 479743 - Samba crashes with CUPS printing in 3.2.7
Samba crashes with CUPS printing in 3.2.7
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
http://lists.samba.org/archive/samba/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 15:28 EST by John Holmstadt
Modified: 2009-02-04 21:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 21:15:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for SWAT includes (267 bytes, patch)
2009-01-21 12:06 EST, Jan Wenzel
no flags Details | Diff

  None (edit)
Description John Holmstadt 2009-01-12 15:28:01 EST
Description of problem:
Samba processes crash with TDB file access errors when using CUPS. Various TDB-related issues occur: Windows clients cannot print via Samba, drivers disappear, printer shares disappear, etc.

Version-Release number of selected component (if applicable):
samba-3.2.7-0.23.fc9.i386

How reproducible:
Unable to determine what causes the crash, but the problem frequently occurs within and hour of startup. 

Additional info:
From /var/log/messages:
[2009/01/10 14:51:53,  0] lib/util_tdb.c:tdb_log(682)
  tdb(/var/lib/samba/ntforms.tdb): tdb_reopen: file dev/inode has changed!
[2009/01/10 14:51:53,  0] lib/util.c:reinit_after_fork(1050)
  tdb_reopen_all failed.
[2009/01/10 14:51:53,  0] smbd/server.c:open_sockets_smbd(744)
  reinit_after_fork() failed
[2009/01/10 14:51:53,  0] lib/util.c:smb_panic(1663)
  PANIC (pid 30698): reinit_after_fork() failed
[2009/01/10 14:51:53,  0] lib/util.c:log_stack_trace(1767)
  BACKTRACE: 6 stack frames:
   #0 smbd(log_stack_trace+0x2d) [0xb7ba313d]
   #1 smbd(smb_panic+0x2d) [0xb7ba323d]
   #2 smbd [0xb7de4e30]
   #3 smbd(main+0x850) [0xb7de57d0]
   #4 /lib/libc.so.6(__libc_start_main+0xe6) [0x3c75d6]
   #5 smbd [0xb7972c11]
[2009/01/10 14:51:53,  0] lib/fault.c:dump_core(201)
  dumping core in /var/log/samba/cores/smbd


Jeremy Allison posted a patch which is said to fix the problem (http://lists.samba.org/archive/samba/2008-December/145677.html), however I cannot get it to compile. It fails with this error:
/usr/src/redhat/BUILD/samba-3.2.7/source/printing/print_cups.c:391: undefined reference to `close_all_print_db'
Comment 1 Jan Wenzel 2009-01-21 12:06:16 EST
Created attachment 329623 [details]
Patch for SWAT includes

This patch allows samba to compile with the patch from jeremy applied.
Comment 2 Jan Wenzel 2009-01-21 12:07:27 EST
With the patch from jeremy, it works for me. There are no panics anymore, printing is functional.

I've added a patch which allows samba to compile with the patch from jeremy applied.
Comment 3 Fedora Update System 2009-02-04 21:15:32 EST
samba-3.2.8-0.25.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.