Bug 479757 - Occasional failure to set correct USB device permissions for Canon EOS camera
Occasional failure to set correct USB device permissions for Canon EOS camera
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-12 16:38 EST by James Ettle
Modified: 2010-06-28 07:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 07:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Ettle 2009-01-12 16:38:14 EST
Description of problem:
Every so often, when I plug in my Canon EOS 400D camera, the USB device permissions are not set up correctly, and a message

   Error initialising camera: -53: Could not claim the USB device

is delivered to the desktop. The INCORRECT permissions are:

[james@rhapsody ~]$ getfacl /dev/bus/usb/002/009 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/002/009
# owner: root
# group: root

whereas they should be:

[james@rhapsody ~]$ getfacl /dev/bus/usb/002/010 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/002/010
# owner: root
# group: root

Version-Release number of selected component (if applicable):

How reproducible:
Intermittent, 20% failure?

Steps to Reproduce:
1. Plug in camera.
2. Switch on.
3. Repeat until failure.
Comment 1 Scott Glaser 2009-09-09 08:41:33 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

Fedora Bugzappers volunteer triage team
Comment 2 James Ettle 2009-09-10 05:14:08 EDT
Still there (takes a few goes to get it to happen):

usb 2-1: new high speed USB device using ehci_hcd and address 8
usb 2-1: New USB device found, idVendor=04a9, idProduct=3110
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1: Product: Canon Digital Camera
usb 2-1: Manufacturer: Canon Inc.
usb 2-1: configuration #1 chosen from 1 choice

$ getfacl /dev/bus/usb/002/008 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/002/008
# owner: root
# group: root

Comment 3 Bug Zapper 2010-04-27 08:43:35 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 4 Bug Zapper 2010-06-28 07:05:54 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.