Bug 479760 - [PATCH] add support for virtio_blk devices to grub-install
[PATCH] add support for virtio_blk devices to grub-install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-01-12 16:50 EST by Nate Clark
Modified: 2009-04-30 12:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 498388 (view as bug list)
Environment:
Last Closed: 2009-04-30 12:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to allow grub-install to work on virtio_blk devices. (952 bytes, patch)
2009-01-12 16:50 EST, Nate Clark
no flags Details | Diff

  None (edit)
Description Nate Clark 2009-01-12 16:50:23 EST
Created attachment 328792 [details]
Patch to allow grub-install to work on virtio_blk devices.

Description of problem:
grub-install does not support installing on virtio_blk devices. When attempted it prints the error message "/dev/vda1 does not have any corresponding BIOS drive."

Version-Release number of selected component (if applicable):
grub-0.97-38.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. Install FC10 in vm that supports virtio_blk devices
2. Install /boot on a virtio_blk device
3. execute $ grub-install /dev/vda1
  
Actual results:
Error message displayed:
/dev/vda1 does not have any corresponding BIOS drive

Expected results:
Grub installs on virtio_blk device

Additional info:
Attached is a patch that worked for me to fix the issue.
Comment 1 lexual 2009-03-01 04:43:12 EST
*** Bug 484986 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2009-03-20 12:29:11 EDT
pjones: does Nate's patch look reasonable?
Comment 3 Jan ONDREJ 2009-04-29 07:26:41 EDT
I have similar problems with Fedora 11-Preview. 11-Beta works but after installing 11-Preview in same virtual machine, GRUB is not installed. More information on fedora-virt mailinglist.

https://www.redhat.com/archives/fedora-virt/2009-April/msg00269.html

Is this a separate bug?
Comment 4 Peter Jones 2009-04-29 17:28:22 EDT
This looks fine, it's in -50 .
Comment 5 Mark McLoughlin 2009-04-30 03:21:49 EDT
tag request: https://fedorahosted.org/rel-eng/ticket/1692

* Wed Apr 29 2009 Peter Jones <pjones@redhat.com> - 0.97-50
- Handle virtio_blk disks and their crazy new device name in grub-install
  (rhbz#479760)
Comment 6 Mark McLoughlin 2009-04-30 04:52:36 EDT
Just tested, -50 seems to work fine
Comment 7 Mark McLoughlin 2009-04-30 12:30:21 EDT
Tagged now, closing

Note You need to log in before you can comment on or make changes to this bug.