Bug 479791 - sound converter does not convert anything
sound converter does not convert anything
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: soundconverter (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 23:29 EST by cornel panceac
Modified: 2009-01-14 12:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 05:22:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2009-01-12 23:29:26 EST
Description of problem:
if i try to convert an flac or an mp3 to ogg there's no output file, only directory structure.

Version-Release number of selected component (if applicable):
$ rpm -q soundconverter
soundconverter-1.3.2-1.fc10.noarch


How reproducible:
always

Steps to Reproduce:
1.select file to convert
2.convert
3.
  
Actual results:
no file

Expected results:
the converted file

Additional info:
same thing happened in fedora 9
Comment 1 Denis Leroy 2009-01-13 02:24:48 EST
Hmmm, WORKSFORME.

So what kind of preferences have you selected in the Preferences menu ? If you select "same folder as input file" for the output, does it work ? What if you add a single MP3 instead of a directory ?
Comment 2 cornel panceac 2009-01-13 03:43:19 EST
no, the output is in a different directory. 
as i said, it creates the directory structure (artist/album) but not the file itself.
however, after reporting this bug, i've tried to do it on another filesystem and, as strange as it may seem, it worked! 

i'll test more later, when i'll be back from work. 
and it's the same if i choose a dir or a single file.
Comment 3 cornel panceac 2009-01-13 12:09:21 EST
on the same file system where i've seen the original bug (that is the /home partition), i've created another directory. the buggy place is /home/guzu/work.usbplayer/converted. the new dir is /home/guzu/converted, and it can create files there. after the conversion is done, i'll try again the buggy place.
Comment 4 cornel panceac 2009-01-13 12:45:38 EST
now it works where it didn't worked before. maybe the config file from a previous version was not "acceptable" for the newer version and changing the path once, forced soundconverter to rewrite the config file in the correct format. i have no other idea :)
Comment 5 Denis Leroy 2009-01-14 05:22:34 EST
Hmmm, well there *are* bugs in Soundconverter :-), so it's just a matter of figuring out what went wrong here. Possibly it could be the config file. I'm going to close this as WORKSFORME for now, but feel free to reopen if you find out more about this. Thanks!
Comment 6 cornel panceac 2009-01-14 12:24:33 EST
ok, assuming this bug will not hit anyone else, let it be closed :)
thank you too.

Note You need to log in before you can comment on or make changes to this bug.