Bug 479808 - Error in HP P1005 printing
Error in HP P1005 printing
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 04:30 EST by antonio montagnani
Modified: 2009-09-08 21:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 10:19:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Troubleshooting file (10.50 KB, text/plain)
2009-01-13 05:34 EST, antonio montagnani
no flags Details
Cups error log (62.38 KB, application/octet-stream)
2009-01-13 06:09 EST, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2009-01-13 04:30:51 EST
Description of problem:
I cannot print on HP P1005 network connected

Version-Release number of selected component (if applicable):
I updated some packages to updates testing in particular:

Jan 13 10:11:54 Updated: hplip-libs.i386 2.8.12-1.fc10
Jan 13 10:11:54 Updated: hal-libs.i386 0.5.12-14.20081027git.fc10
Jan 13 10:12:09 Updated: gutenprint.i386 5.2.3-1.fc10
Jan 13 10:12:20 Updated: gutenprint-foomatic.i386 5.2.3-1.fc10
Jan 13 10:12:29 Updated: hpijs.i386 1:2.8.12-1.fc10
Jan 13 10:12:30 Updated: hal-info.noarch 20081219-1.fc10
Jan 13 10:12:34 Updated: hal.i386 0.5.12-14.20081027git.fc10
Jan 13 10:12:42 Updated: hplip.i386 2.8.12-1.fc10
Jan 13 10:12:48 Updated: hplip-gui.i386 2.8.12-1.fc10

How reproducible:


Steps to Reproduce:
1.print test page in System-config-printer
2.
3.
  
Actual results:
No printing .
I get the message that printer is waiting-/usr/libs/cups/filter/foomatic-rip failed

Expected results:
print

Additional info:

Page 1 (Scheduler not running?):
{'cups_connection_failure': False}
Page 2 (Choose printer):
{'cups_dest': <cups.Dest HP-LaserJet-10052>,
 'cups_instance': None,
 'cups_queue': 'HP-LaserJet-10052',
 'cups_queue_listed': True}
Page 3 (Check printer sanity):
{'cups_device_uri_scheme': u'smb',
 'cups_printer_dict': {'device-uri': u'smb://WORKGROUP/PC-CONTEC/HP%20LaserJet%20P1005',
                       'printer-info': u'HP LaserJet 1005',
                       'printer-is-shared': True,
                       'printer-location': u'',
                       'printer-make-and-model': u'HP LaserJet 1005 Series Foomatic/hpijs, hpijs 2.8.12',
                       'printer-state': 3,
                       'printer-state-message': u'/usr/lib/cups/filter/foomatic-rip failed',
                       'printer-state-reasons': [u'none'],
                       'printer-type': 36876,
                       'printer-uri-supported': u'ipp://localhost:631/printers/HP-LaserJet-10052'},
 'cups_printer_remote': False,
 'is_cups_class': False,
 'nmblookup_output': ('querying PC-CONTEC on 192.168.0.255\n192.168.0.157 PC-CONTEC<00>\n',
                      ''),
 'remote_server_name': '192.168.0.157'}
Page 4 (Check PPD sanity):
{'cups_printer_ppd_defaults': {u'General': {u'InputSlot': u'Default',
                                            u'MediaType': u'Plain',
                                            u'PageRegion': u'A4',
                                            u'PageSize': u'A4',
                                            u'PrintoutMode': u'Normal'},
                               u'PrintoutMode': {u'Quality': u'FromPrintoutMode'}},
 'cups_printer_ppd_valid': True,
 'missing_pkgs_and_exes': ([], [])}
Page 5 (Locale issues):
{'system_locale_lang': 'it_IT',
 'user_locale_ctype': 'it_IT',
 'user_locale_messages': 'it_IT'}
Page 6 (Local or remote?):
{'printer_is_remote': False}
Page 7 (Check network server sanity):
{'remote_server_name_resolves': ['192.168.0.157',
                                 '192.168.0.157',
                                 '192.168.0.157'],
 'remote_server_smb': True,
 'remote_server_smb_shares': [<smbc.Dirent object "ADMIN$" (File share) at 0x8e5b7e8>,
                              <smbc.Dirent object "C$" (File share) at 0x8e74d58>,
                              <smbc.Dirent object "HP LaserJet P1005" (Printer share) at 0x8e74d70>,
                              <smbc.Dirent object "IPC$" (IPC share) at 0x8e74d88>,
                              <smbc.Dirent object "print$" (File share) at 0x8e74da0>,
                              <smbc.Dirent object "Public" (File share) at 0x8e74db8>],
 'remote_server_traceroute': (['traceroute to 192.168.0.157 (192.168.0.157), 30 hops max, 60 byte packets',
                               ' 1  192.168.0.157 (192.168.0.157)  1.794 ms * *',
                               ''],
                              ['']),
 'remote_server_try_connect': '192.168.0.157'}
Page 8 (Printer state reasons):
{'printer-state-message': u'/usr/lib/cups/filter/foomatic-rip failed',
 'printer-state-reasons': [u'none']}
Page 9 (Error log checkpoint):
{'cups_server_settings': {'DefaultAuthType': 'Basic',
                          'MaxLogSize': '0',
                          'SystemGroup': 'sys root',
                          '_debug_logging': '1',
                          '_remote_admin': '0',
                          '_remote_any': '0',
                          '_remote_printers': '1',
                          '_share_printers': '0',
                          '_user_cancel_any': '0'},
 'error_log_checkpoint': 8764119L}
Page 10 (Print test page):
{'test_page_job_status': [(True,
                           246,
                           'HP-LaserJet-10052',
                           'Test Page',
                           'Arrestata',
                           {'attributes-charset': u'utf-8',
                            'attributes-natural-language': u'it-it',
                            'document-format': u'application/postscript',
                            'job-hold-until': u'no-hold',
                            'job-id': 246,
                            'job-k-octets': 17,
                            'job-media-sheets-completed': 0,
                            'job-more-info': u'ipp://localhost:631/jobs/246',
                            'job-name': u'Test Page',
                            'job-originating-host-name': u'localhost',
                            'job-originating-user-name': u'antonio',
                            'job-preserved': True,
                            'job-printer-state-message': u'/usr/lib/cups/filter/foomatic-rip failed',
                            'job-printer-state-reasons': [u'none'],
                            'job-printer-up-time': 1231839005,
                            'job-printer-uri': u'ipp://acerF10:631/printers/HP-LaserJet-10052',
                            'job-priority': 50,
                            'job-sheets': [u'none', u'none'],
                            'job-state': 6,
                            'job-state-reasons': u'job-stopped',
                            'job-uri': u'ipp://localhost:631/jobs/246',
                            'job-uuid': u'urn:uuid:62ff200b-7e8d-3a80-751c-bb48cff86e63',
                            'printer-uri': u'ipp://localhost/printers/HP-LaserJet-10052',
                            'time-at-completed': None,
                            'time-at-creation': 1231838232,
                            'time-at-processing': 1231838232}),
                          (False,
                           247,
                           'HP-LaserJet-10052',
                           'Test Page',
                           'Arrestata',
                           None)],
 'test_page_successful': True}
Page 11 (Error log fetch):
{'error_log': ['D [13/Jan/2009:10:29:57 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:29:57 +0100] cupsdReadClient: 12 POST / HTTP/1.1',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAuthorize: No authentication data provided.',
               'D [13/Jan/2009:10:29:57 +0100] Get-Jobs ipp://localhost/printers/',
               'D [13/Jan/2009:10:29:57 +0100] [Job 246] Loading attributes...',
               'D [13/Jan/2009:10:29:57 +0100] [Job 247] Loading attributes...',
               'D [13/Jan/2009:10:29:57 +0100] cupsdProcessIPPRequest: 12 status_code=0 (successful-ok)',
               'D [13/Jan/2009:10:29:57 +0100] cupsdCloseClient: 12',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:29:57 +0100] cupsdReadClient: 12 POST / HTTP/1.1',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAuthorize: No authentication data provided.',
               'D [13/Jan/2009:10:29:57 +0100] Create-Printer-Subscription /',
               'D [13/Jan/2009:10:29:57 +0100] cupsdCreateSubscription(con=0xb8edf400(12), uri="/")',
               'D [13/Jan/2009:10:29:57 +0100] pullmethod="ippget"',
               'D [13/Jan/2009:10:29:57 +0100] notify-lease-duration=86400',
               'D [13/Jan/2009:10:29:57 +0100] notify-time-interval=0',
               'D [13/Jan/2009:10:29:57 +0100] cupsdAddSubscription(mask=17800, dest=(nil)(), job=(nil)(0), uri="(null)")',
               'D [13/Jan/2009:10:29:57 +0100] Added subscription 189 for server',
               'I [13/Jan/2009:10:29:57 +0100] Saving subscriptions.conf...',
               'D [13/Jan/2009:10:29:57 +0100] cupsdProcessIPPRequest: 12 status_code=0 (successful-ok)',
               'D [13/Jan/2009:10:29:57 +0100] cupsdCloseClient: 12',
               'D [13/Jan/2009:10:29:58 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:29:58 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:29:58 +0100] cupsdReadClient: 12 POST / HTTP/1.1',
               'D [13/Jan/2009:10:29:58 +0100] cupsdAuthorize: No authentication data provided.',
               'D [13/Jan/2009:10:29:58 +0100] Get-Notifications /',
               'D [13/Jan/2009:10:29:58 +0100] cupsdIsAuthorized: requesting-user-name="root"',
               'D [13/Jan/2009:10:29:58 +0100] cupsdProcessIPPRequest: 12 status_code=0 (successful-ok)',
               'D [13/Jan/2009:10:29:58 +0100] cupsdCloseClient: 12',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:30:05 +0100] cupsdReadClient: 12 POST / HTTP/1.1',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAuthorize: No authentication data provided.',
               'D [13/Jan/2009:10:30:05 +0100] Get-Job-Attributes ipp://localhost/jobs/246',
               'D [13/Jan/2009:10:30:05 +0100] cupsdProcessIPPRequest: 12 status_code=0 (successful-ok)',
               'D [13/Jan/2009:10:30:05 +0100] cupsdCloseClient: 12',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:30:05 +0100] cupsdReadClient: 12 POST / HTTP/1.1',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAuthorize: No authentication data provided.',
               'D [13/Jan/2009:10:30:05 +0100] Cancel-Subscription /',
               'D [13/Jan/2009:10:30:05 +0100] cupsdIsAuthorized: requesting-user-name="root"',
               'I [13/Jan/2009:10:30:05 +0100] Saving subscriptions.conf...',
               'D [13/Jan/2009:10:30:05 +0100] cupsdProcessIPPRequest: 12 status_code=0 (successful-ok)',
               'D [13/Jan/2009:10:30:05 +0100] cupsdCloseClient: 12',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: skipping getpeercon()',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAcceptClient: 12 from localhost (Domain)',
               'D [13/Jan/2009:10:30:05 +0100] cupsdCloseClient: 9',
               'D [13/Jan/2009:10:30:05 +0100] cupsdReadClient: 12 GET /admin/log/error_log HTTP/1.1',
               'D [13/Jan/2009:10:30:05 +0100] cupsdAuthorize: No authentication data provided.']}
Comment 1 antonio montagnani 2009-01-13 04:32:51 EST
I forgot to mention that printer is on a Windows Vista PC.
Comment 2 Tim Waugh 2009-01-13 05:23:08 EST
Somehow the error_log has been truncated before we were able to fetch it.

Please run '/sbin/service cups restartlog' first, and then try the troubleshooter again.
Comment 3 antonio montagnani 2009-01-13 05:34:25 EST
Created attachment 328851 [details]
Troubleshooting file

after service cups restartlog
Comment 4 Tim Waugh 2009-01-13 06:04:22 EST
Please attach /var/log/cups/error_log in full.  For some reason it doesn't all seem to be getting captured.  Sorry.
Comment 5 antonio montagnani 2009-01-13 06:09:29 EST
Created attachment 328855 [details]
Cups error log
Comment 6 Tim Waugh 2009-01-13 09:06:33 EST
The problem seems to be that hpijs is segfaulting.

$ gs '-dBATCH' '-dPARANOIDSAFER' '-dNOPAUSE' '-sDEVICE=ijs' \
'-sIjsServer=hpijs' '-dDEVICEWIDTHPOINTS=595' \
'-dDEVICEHEIGHTPOINTS=842' '-sDeviceManufacturer=HEWLETT-PACKARD' \
'-sDeviceModel=HP LaserJet 1018' '-r600' \
'-sIjsParams=Quality:Quality=0,Quality:ColorMode=0
,Quality:PenSet=0Plain,PS:MediaPosition=7' 
GPL Ghostscript 8.63 (2008-08-01)
Copyright (C) 2008 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
unable to set key=OutputFile, value=
**** Unable to open the initial device, quitting.
$ file core.23638 
core.23638: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style, from 'hpijs'
Comment 7 Tim Waugh 2009-01-13 10:19:12 EST
Oh, this just seems to be due to DEVICE_URI and PRINTER environment variables not being set.  Will fix that.

However, the main problem is this:

$ gs '-dBATCH' '-dPARANOIDSAFER' '-dNOPAUSE' '-sQUIET' \
'-sDEVICE=ijs' '-sIjsServer=hpijs' '-dDEVICEWIDTHPOINTS=595' \
'-dDEVICEHEIGHTPOINTS=842' '-sDeviceManufacturer=HEWLETT-PACKARD' \
'-sDeviceModel=HP LaserJet 1018' '-r600' \
'-sIjsParams=Quality:Quality=0,Quality:ColorMode=0
,Quality:PenSet=0Plain,PS:MediaPosition=7' 
unable to set key=OutputFile, value=/dev/stdout
unable to set device=HP LaserJet 1018, err=48
unable to set device=HP LaserJet 1018, err=48
**** Unable to open the initial device, quitting.
unable to read client data err=-2

This error number, 48, means that there is a missing required (proprietary) plug-in for this device.

Nothing we can do about that I'm afraid. (You could try 'hp-setup'.)
Comment 8 antonio montagnani 2009-01-13 11:24:22 EST
Shall I assume that I will have same problem in F11??? see my other bug
Comment 9 Tim Waugh 2009-01-13 11:51:17 EST
Yes: basically you can't use hpijs with that printer.

However, looking at the OpenPrinting database it looks like there's another one you can use:
  http://openprinting.org/show_printer.cgi?recnum=HP-LaserJet_P1005
Comment 10 antonio montagnani 2009-01-14 03:28:21 EST
I confirm that it works with alternative driver.
So bug can be closed
Comment 11 epicoponte 2009-09-08 21:15:28 EDT
Had same problem trying to install an HP Laserjet 1000, network printer in Windows OS, using Fedora 11.  Error messages:

unable to set device=HP LaserJet 1018, err=48
unable to set device=HP LaserJet 1018, err=48
**** Unable to open the initial device, quitting.
unable to read client data err=-2

Had previously installed it from repos that come with Fedora 11, as a Samba Network Printer.  Did not work, got the above error messages.

Used driver in Openprinting.org, following instructions. Installed quickly and worked at first try. Lost many hours for not reading the error logs when they first came out.  

Web addresses used were:

http://www.openprinting.org/show_printer.cgi?recnum=HP-LaserJet_1000

http://www.openprinting.org/show_driver.cgi?driver=foo2zjs&fromprinter=HP-LaserJet_1000

http://foo2zjs.rkkda.com/

http://foo2zjs.rkkda.com/fedora/hp1020.html

Hope this may be useful.

Note You need to log in before you can comment on or make changes to this bug.