This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 479824 - RFE: iBFT network configuration mode support in NM [NEEDINFO]
RFE: iBFT network configuration mode support in NM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
: 467865 485353 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 07:31 EST by Martin Sivák
Modified: 2014-05-29 11:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 11:57:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
dcbw: needinfo? (msivak)


Attachments (Terms of Use)

  None (edit)
Description Martin Sivák 2009-01-13 07:31:31 EST
Description of problem:

Due to ongoing work for iSCSI support in Fedora and RHEL, we need to support BOOTPROTO=ibft in ifcfg- configuration scripts.

For related info see bug 445721 and command iscsiadm -m fw.

Example output from this command follows:

# [root@elm3b87 ~]# iscsiadm -m fw
# iface.initiatorname = iqn.2007-05.com.ibm.beaverton.elm3b87:01
# iface.hwaddress = 00:14:5e:b3:8e:b2

# iface.bootproto = DHCP
# or
# iface.bootproto = STATIC
# iface.ipaddress = 192.168.32.72
# iface.subnet_mask = 255.255.252.0
# iface.gateway = 192.168.35.254

# node.name = iqn.1992-08.com.netapp:sn.84183797
# node.conn[0].address = 9.47.67.152
# node.conn[0].port = 3260


Version-Release number of selected component (if applicable):

Needed for F11.

Expected results:

When ifcfg-nic contains the BOOTPROTO=ibft, NM launches iscsiadm, reads the network settings, compares MAC addresses for match and if successful, sets the network card configuration according to the values in iBFT table.
Comment 1 Dan Williams 2009-01-26 10:34:19 EST
Is there no way to inspect the iSCSI stuff other than to launch iscsiadm?  That should seriously be a library.  Launching binaries and screenscraping the results is just fragile.
Comment 2 Martin Sivák 2009-01-27 10:23:11 EST
hansg and mchristi are preparing libiscsi for Fedora. It has already been reviewed and I'm waiting for the iBFT specific parts to get there.
Comment 3 Martin Sivák 2009-01-28 11:22:11 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=80624

This build of iscsi-initiator-utils contains code which allows you to read the values using C library.
Comment 4 Dan Williams 2009-02-13 08:14:45 EST
*** Bug 467865 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2009-02-13 10:40:58 EST
*** Bug 485353 has been marked as a duplicate of this bug. ***
Comment 6 Vishnu V 2009-04-11 06:42:53 EDT
Need to also use IBFT VLAN configuration for the interface
Comment 7 Niels Haase 2009-04-28 18:01:21 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Dan Williams 2009-08-06 16:09:25 EDT
Anyone have any idea what iscsiadm -m fw output looks like when more than one iscsi device is configured in the system?
Comment 10 Dan Winship 2012-05-08 09:00:40 EDT
dcbw: fixed as of F17, right?
Comment 11 Dan Williams 2014-05-29 11:57:16 EDT
(In reply to Dan Winship from comment #10)
> dcbw: fixed as of F17, right?

Yes, except for VLAN support which is tracked by other bugs.

Note You need to log in before you can comment on or make changes to this bug.