Bug 479834 - EC2E doesn't work on RHEL4
EC2E doesn't work on RHEL4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
low Severity medium
: 1.2
: ---
Assigned To: Robert Rati
Jeff Needle
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 09:25 EST by Robert Rati
Modified: 2009-09-10 14:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.2.2.0.9+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-01-13 09:25:08 EST
Description of problem:
The EC2E feature does not successfully complete on RHEL4.  The job is translated and executed in EC2 correctly, but the finalize hook doesn't find the job attribute to denote that the job completed successfully so it forces the job to be re-routed.

Version-Release number of selected component (if applicable):
7.2.0-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-01-13 09:27:22 EST
This is caused by the condor hooks pipe handling combined with RHEL4's pipe buffer size of 4k.  With condor's implementation, it is only possible to pass a kernel's pipe buffer size of data to the child hook and on pre-2.6.11 kernels the pipe buffer size of 4k (2.6.11+ is pipe buffer size is 65k).
Comment 2 Robert Rati 2009-04-02 12:01:52 EDT
Pipe handling was re-worked to remove artificial limitations.  Fixed in the next build post:

condor-7.2.2-0.9
Comment 3 Luigi Toscano 2009-09-01 12:41:20 EDT
Is this still a bug? The last version of python-boto, required by the new EC2E API[1], requires python 2.5, with a best-effort support for python 2.4. 
Do we support this version of boto on RHEL 4 (python 2.3), or is this functionality not supported anymore on RHEL 4?

[1] https://rhn.redhat.com/errata/RHEA-2009-1187.html
[2] http://code.google.com/p/boto/
Comment 4 Robert Rati 2009-09-09 10:52:26 EDT
There was a bug in condor that prevented the hooks from working with EC2E.  That has been fixed, but the new python-boto package hasn't been tested on RHEL4.  The author states he attempts to keep python2.4 compatibility, but doesn't guarantee it nor test against it.  We had to make changes to the 1.0a version for EC2E to work and it is possible such issues exist in the new boto.  It was decided to leave RHEL4 unsupported for EC2E at this time due to uncertainties with the boto package.
Comment 5 Jeff Needle 2009-09-09 11:37:39 EDT
Moving back to ASSIGNED state to make sure that we do the proper messaging and whatever else might be necessary to retire an already shipping product.

Note You need to log in before you can comment on or make changes to this bug.