Bug 479841 - amarok-2.0-2.fc10.i386 does not run.
amarok-2.0-2.fc10.i386 does not run.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 10:10 EST by vikram goyal
Modified: 2009-01-13 11:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 10:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
err messages on console (9.40 KB, text/plain)
2009-01-13 10:10 EST, vikram goyal
no flags Details

  None (edit)
Description vikram goyal 2009-01-13 10:10:59 EST
Created attachment 328869 [details]
err messages on console

Description of problem:
amarok started from cmd line for err messages. attached
Playing a file it err out the following message.
QString::arg: Argument missing: Amarok - No track playing., 0:00
The same runs ok in other applications.

Version-Release number of selected component (if applicable):
2.0-2.fc10

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2009-01-13 10:14:39 EST
Which DE in use?  gnome?  kde?

Does
yum update @sound-and-video
install anything that was previously missing?
Comment 2 vikram goyal 2009-01-13 10:29:52 EST
Kde is in use.

I checked the install with package-cleanup --problems and there was no dependency
missing

Then I did as you told me and yum pulled in two packages:

libtunepimp-extras-freeworld.i386
xine-lib-extras-freeworld.i386

which solved the problem. yum update @sound-and-video is a new command for me.

I think these packages should have been pulled in automatically or package-cleanup should have reported them missing

Thanks!
Comment 3 Rex Dieter 2009-01-13 10:36:48 EST
Can't add hard deps, as those packages are not in fedora. 

In short, you were trying to play nonfree/pantented media files, for which fedora doesn't support out of the box (ie, mp3's, etc...).

Fwiw, it *is* documented at amarok's site
http://amarok.kde.org/wiki/Download:Fedora

and probably should be @ rpmfusion as well.
Comment 4 Rex Dieter 2009-01-13 10:37:28 EST
That said, amarok's feedback for when trying to play unsupported filetypes can/should be more informative (other than simply not working).
Comment 5 vikram goyal 2009-01-13 11:43:43 EST
I understand, but actually I never came across this before with amarok,
I mean such dependencies used to get pulled in.

This is the only application I use to listen to music for quite long now and
since the version changed and it was not working and there was no way I could
make out what was happening as I thought I had all rpms installed to listen to
mp3s, also the same mp3s were running in xmms etc

If amarok can inform the user about missing plugins it will become more helpful
to understand its not amarok but something else. Even a message to try 'yum @sound-and-video' can be helpful to fill in the rpm gaps.

Thanks for helping me out and use amarok.

Note You need to log in before you can comment on or make changes to this bug.