Bug 479846 - git repo version is still setting fstype too late
git repo version is still setting fstype too late
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 10:36 EST by Bruno Wolff III
Modified: 2009-04-13 12:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 11:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-01-13 10:36:30 EST
Description of problem:
I tested the git repo version of livecd-tools from yesterday and it was still setting the fstype to udf too late even after the check got moved. This included through the change with the comment "Fix stpuid typo".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run livecd-creator on the games spin kickstart
2. Burn to DVD
3. Try to boot off DVD
  
Actual results:
Boot fails with a message indicating the fs type didn't match.

Expected results:
Successful boot

Additional info:
Are you sure you need to even specify the file system type? Does it get misdetected if you don't?
Comment 1 Bruno Wolff III 2009-01-14 10:25:26 EST
I did try taking out the rootfstype stuff to see if it was necessary and the boot did end up failing with a mount not able to recognize the type. So it does appear some guidance is necessary. It's kind of odd since I can mount the iso without specifying a type normally. The boot process also starts normally, so the bios sees things OK. And the the initial kernel appears to load OK.
Comment 2 Jeremy Katz 2009-01-19 11:20:11 EST
Okay, went a step further and made rootfstype=auto do the right thing in the initrd and switched to using that.  This may mean that we don't entirely act nicely for > 4GB images with older distros, but I think the only thing that really would have gotten lost would be the checkisomd5 bits.  And those were getting dropped for udf as well as auto
Comment 3 Bruno Wolff III 2009-01-19 13:15:50 EST
FYI. The spins SIG decided in today's meeting that the alpha games spin iso should be under 4 GiB. This will be reevaluated at the beta. So there is less hurry to do this patch. I'll continue to test it with a private kickstart file, but for tonight I'll be updating a pruned down live games spin kickstart.
Comment 4 Alan Pevec 2009-02-20 10:13:34 EST
http://git.fedorahosted.org/git/?p=livecd;a=commit;h=616642a5d56b8e453614f7a8845a61b033c9ac4f

this broke media check, it is never performed, even with check bootparameter. livecd initrd has this condition:
if [ "x$check_iso" == "x1" -a -x /bin/checkisomd5 -a "x$rootfstype" ==
"xiso9660" ]; then ...

Could initrd be made smarter when checking filesystem type, instead of relying on bootparameter value?
Comment 5 Jeremy Katz 2009-02-20 10:51:41 EST
(In reply to comment #4)
> Could initrd be made smarter when checking filesystem type, instead of relying
> on bootparameter value?

That was done at the same time :-)   See 24d6d9779ca5bacc0c649e9d783263661ceb81f0 of mkinitrd
Comment 6 Bruno Wolff III 2009-04-13 11:09:21 EDT
This has been fixed for a while now.

Note You need to log in before you can comment on or make changes to this bug.