Bug 479971 - Use of uninitialized value in chown at /usr/bin/rhn-generate-pem.pl line 74.
Use of uninitialized value in chown at /usr/bin/rhn-generate-pem.pl line 74.
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2009-01-14 06:00 EST by Miroslav Suchý
Modified: 2009-01-22 11:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 11:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2009-01-14 06:00:29 EST
Description of problem:
During installation I got this error:
spacewalk-setup --disconnected
...
** SSL: Deploying CA certificate.
** SSL: Generating server certificate.
** SSL: Storing SSL certificates.
Use of uninitialized value in chown at /usr/bin/rhn-generate-pem.pl line 74.
Use of uninitialized value in chown at /usr/bin/rhn-generate-pem.pl line 74.
* Deploying configuration files.

The problem seems to be in this lines:
 my ($uid, $gid) = lookup_user_ids('jabberd');
 chown($uid, $gid, $out_file);
and in the fact that jabberd is not installed by default.


Version-Release number of selected component (if applicable):
Spacewalk from nighlty repo.

Additional info:
# grep jabberd /etc/passwd
# rpm -qi jabberd
package jabberd is not installed
Comment 1 Jan Pazdziora 2009-01-14 06:11:23 EST
Fixed in 8097ccbf0179f8691a8caa3a028e45ee861b33a5.
Comment 2 Jan Pazdziora 2009-01-16 08:58:56 EST
Actually, the fix made it to spacewalk-setup-0.4.22-1, and Spacewalk 0.4 shipped with spacewalk-setup-0.4.23-1.el5, to moving to space04.
Comment 3 Michael Mráka 2009-01-22 04:56:32 EST
Verified. spacewalk-setup-0.5.2-1

...
* Creating SSL certificates.
** SSL: Generating CA certificate.
** SSL: Deploying CA certificate.
** SSL: Generating server certificate.
** SSL: Storing SSL certificates.
* Deploying configuration files.
* Update configuration in database.
* Setting up Cobbler..
* Restarting services.
Installation complete.


# grep jabberd /etc/passwd
jabberd:x:100:101:Jabber Daemon:/:/bin/false
# rpm -q jabberd
jabberd-2.0s10-3.42.el5.x86_64

Note You need to log in before you can comment on or make changes to this bug.