Bug 479991 - "Solar" background theme broken wrt kde42
"Solar" background theme broken wrt kde42
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: solar-kde-theme (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde42
  Show dependency treegraph
 
Reported: 2009-01-14 09:36 EST by Rex Dieter
Modified: 2009-01-24 04:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-24 04:05:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.08 KB, patch)
2009-01-15 10:01 EST, Jaroslav Reznik
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 180716 None None None Never

  None (edit)
Description Rex Dieter 2009-01-14 09:36:40 EST
Seems the Solar background theme is indeed broken when used with kde-4.2.  In my testing, it seems to have to do with the use of symlinks.

If I replace the symlinks with real images, it works.
Comment 1 Rex Dieter 2009-01-14 13:46:28 EST
Tried for advice on irc... nada, filed upstream bug.
Comment 2 Jaroslav Reznik 2009-01-15 04:35:40 EST
Wallpapers are now separated into standalone components - so I think it's complete rewrite :( See http://websvn.kde.org/trunk/KDE/kdebase/workspace/plasma/design/wallpaper?revision=832566&view=markup.
Comment 3 Jaroslav Reznik 2009-01-15 06:08:14 EST
Well, upstream says it's a feature - no symlinks outside wallpapers package (only inside). What now? Convince upstream it's a regression for us or patch it to support symlinks outside wallpapers package?
Comment 4 Rex Dieter 2009-01-15 08:57:00 EST
I'll explore the possibility of modifying solar-backgrounds and maybe using hardlinks or something similar.
Comment 5 Jaroslav Reznik 2009-01-15 10:01:17 EST
Created attachment 329101 [details]
Proposed patch

Ok, this is our "hyperextreme programming tryout with ltinkl" workaround:

For static content such as wallpapers it should not be such security risk to touch files (images) outside package, so we've set ServiceType to Plasma/Wallpaper for Solar backgrounds package and for packages with this type we allow access outside this packages (so symlinks are again allowed).

But bad packages still could claim they are wallpaper type.

Feel free to comment this patch. It's workaround at least for F10 - it's not easy to change this in package as it's already released. For F11 we can write wallpaper service which will support Gnome backgrounds directly (even with daytime changes of wallpaper).
Comment 6 Kevin Kofler 2009-01-15 18:13:42 EST
Can't we automatically figure out whether it's a wallpaper from the context it's used in? That would be more secure, in addition to not having to modify the Solar theme.
Comment 7 Kevin Kofler 2009-01-15 18:18:39 EST
Oh, and ServiceType=Plasma/Wallpaper is for wallpaper plugins/engines according to the design document you quote, not for wallpaper themes.
Comment 8 Kevin Kofler 2009-01-15 18:24:12 EST
Sorry, a couple more questions: How does this thing interact with my plasma-default-wallpaper patch? Where exactly is Plasma::Package used for the wallpapers?
Comment 9 Jaroslav Reznik 2009-01-16 03:34:22 EST
It's solved by upstream now (thanks aseigo!) and actually it looks much more better than our patch (it adds allowExternalPaths to PackageStructure and then sets it to true in BackroundPackage). It missed 4.2 but we are allowed to backport to our packages :)
Comment 10 Ngo Than 2009-01-16 09:21:14 EST
it's only happen in KDE-4.2, changed Version to rawhide. it's fixed in
kdelibs-4_1_96-9_fc11, kdebase-workspace-4_1_96-4_fc11 and kde-settings-4.1-4.20090116svn-f11
Comment 11 Kevin Kofler 2009-01-24 04:05:28 EST
This is fixed in Rawhide now, F9 and F10 (official packages) not affected, kde-redhat is already fixed too AFAIK, closing.

Note You need to log in before you can comment on or make changes to this bug.