Bug 480014 - authconfig and usermode dependency
Summary: authconfig and usermode dependency
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: F11MinimalPlatform
Blocks: FedoraServerTracker 519838 554536 575256
TreeView+ depends on / blocked
 
Reported: 2009-01-14 15:52 UTC by Peter Vrabec
Modified: 2010-03-19 20:41 UTC (History)
1 user (show)

Fixed In Version: authconfig-5.4.7-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-26 16:59:45 UTC


Attachments (Terms of Use)

Description Peter Vrabec 2009-01-14 15:52:18 UTC
Dear maintainer,

We found an improvement in our minimal installation project, where we want to get a rid of SUID binaries if it's possible.

see this:
anaconda requires authconfig
authconfig requires usermode
usermode includes /usr/sbin/userhelper
/usr/sbin/userhelper is SUID

Could you please split authconfig into 2 packages. So it will look like this:
1. anaconda requires authconfig

2. authconfig-with_consolehelper requires usermode and authconfig

Then we can use only authconfig in the minimal installation.

thnx.

Comment 1 Tomas Mraz 2009-01-26 16:59:45 UTC
I've decided to just move the consolehelper symlinks to the -gtk subpackage. The userhelper subpackage for authconfig would not be reasonably discoverable and any admin who is not interested in the authconfig gui is probably not interested in the usermode support of authconfig either. And he can easily setup sudo to be able to call authconfig from regular user account.


Note You need to log in before you can comment on or make changes to this bug.