Bug 480047 - traceback when running satellite-sync on spacewalk 0.4
traceback when running satellite-sync on spacewalk 0.4
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2009-01-14 13:15 EST by Mike McCune
Modified: 2009-01-15 15:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 15:15:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-01-14 13:15:25 EST
Running: 

satellite-sync -c rhel-i386-server-5  -m /export/

23:16:16
SYNC ERROR: unhandled exception occurred:

Exception reported from test02-vmx
Time: Tue Jan 13 23:16:16 2009
Exception type exceptions.IOError

Exception Handler Information
Traceback (most recent call last):
   File "/usr/bin/satellite-sync", line 142, in main
     return satsync.Runner().main()
   File "/usr/share/rhn/satellite_tools/satsync.py", line 206, in main
     ret = method()
   File "/usr/share/rhn/satellite_tools/satsync.py", line 293, in 
_step_short
     return self.syncer.processShortPackages()
   File "/usr/share/rhn/satellite_tools/satsync.py", line 825, in 
processShortPackages
     self._diff_packages()
   File "/usr/share/rhn/satellite_tools/satsync.py", line 861, in 
_diff_packages
     package = package_collection.get_package(pid, p_timestamp)
   File "/usr/share/rhn/satellite_tools/sync_handlers.py", line 245, in 
get_package
     return self._cache.cache_get(package_id, timestamp=timestamp)
   File "/usr/share/rhn/satellite_tools/syncCache.py", line 41, in cache_get
     compressed=self._compressed)
   File "/usr/share/rhn/common/rhnCache.py", line 71, in get
     return cache.get(name, modified)
   File "/usr/share/rhn/common/rhnCache.py", line 363, in get
     return self.cache.get(name, modified)
   File "/usr/share/rhn/common/rhnCache.py", line 334, in get
     pickled = self.cache.get(name, modified)
   File "/usr/share/rhn/common/rhnCache.py", line 232, in get
     fd.close()
   File "/usr/share/rhn/common/rhnCache.py", line 175, in close
     _unlock(self.fd.fileno())
   File "/usr/share/rhn/common/rhnCache.py", line 59, in _unlock
     fcntl.fcntl(fd, rhn_fcntl.F_SETLKW, UNLOCK)
IOError: [Errno 22] Invalid argument

If you want to know what box I ran this on just ping me (mmccune/mccun934)
Comment 1 Mike McCune 2009-01-14 14:09:25 EST
Jesus indicates if you use a redhat Satellite Cert vs the one we ship with spacewalk the above error goes away.
Comment 2 Jesus M. Rodriguez 2009-01-15 15:15:08 EST
This works fine. We've run it several times since then without error.

Note You need to log in before you can comment on or make changes to this bug.