Bug 480048 - multipathd doesn't close pipe fds on a failed fork
multipathd doesn't close pipe fds on a failed fork
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.3
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
: ZStream
: 480170 (view as bug list)
Depends On:
Blocks: 481740
  Show dependency treegraph
 
Reported: 2009-01-14 13:17 EST by Ben Marzinski
Modified: 2010-03-14 17:28 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Marzinski 2009-01-14 13:17:32 EST
When multipathd tries to fork a callout, if it fails, it doesn't close the pipe fds necessary to talk to the callout.  Also, when multipathd fails to execute a callout, it doesn't print any useful error messages.
Comment 1 Tom Coughlan 2009-01-15 14:23:35 EST
*** Bug 480170 has been marked as a duplicate of this bug. ***
Comment 3 laurie barry 2009-01-15 19:54:52 EST
Is RH planning to fix this for RHEL5.3?  We need to determine how much longer our test bed/test resources will be consumed with this release and whether we need to regression test another RHEL5.3 RC?

Laurie
Comment 4 Ben Marzinski 2009-01-16 17:55:06 EST
The fix for this is committed. The plan is to release this as a z-stream release.  Although I noticed this bug looking at 478643, as far as I know, nobody has ever hit it.  The error reporting is very helpful to tell if people are running into 478643, and need to increase their max_fds, but as long as you follow the workaround in that bugzilla, you should be fine.
Comment 8 Ben Marzinski 2009-07-08 16:58:16 EDT
The release notes in bz #478643 have all the information that's necessary.
Comment 10 errata-xmlrpc 2009-09-02 07:46:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1377.html

Note You need to log in before you can comment on or make changes to this bug.