Bug 480058 - repoquery can't list RPMs listed in /etc/yum.conf exclude= list
repoquery can't list RPMs listed in /etc/yum.conf exclude= list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 14:40 EST by Valdis Kletnieks
Modified: 2014-01-21 18:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 14:51:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2009-01-14 14:40:55 EST
Description of problem:
So I hit a show-stopper issue with a specific RPM, and can't upgrade until something happens upstream (in this case, it was bug #433649 against gdm, open for several months now).  So I list 'exclude=RPM' in /etc/yum.conf so that it doesn't keep showing up in 'yum list updates', and I can't accidentally do a 'yum update' and forget '--exclude=RPM'.

Unfortunately, it *also* means that to see if the fix has *landed* yet, I need to go edit /etc/yum.conf, remove the RPM from the exclude= list, save it, run 'repoquery --changelog <RPM>', look it over, re-edit yum.conf, re-add the RPM to the exclude= list, and re-save.

It would be helpful if repoquery didn't filter based on the exclude= list.

Version-Release number of selected component (if applicable):
yum-utils-1.1.19-1.fc11.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 seth vidal 2009-01-14 14:51:12 EST
We're unlikely to implement that since repoquery is yum-based and it makes sense to follow yum settings when you do that.

However, you can do:

repoquery -c /path/to/yum.conf

and just have that yum.conf not have the exclude= in it.
Comment 2 James Antill 2009-01-14 14:55:39 EST
You can use --disableexcludes for "yum list updates" ... we could also implement that in repoquery, maybe.
Comment 3 seth vidal 2009-01-14 15:05:17 EST
Notably - if you're happy with all the other defaults in yum you can just do:

repoquery -c /dev/null .....

-sv
Comment 4 Valdis Kletnieks 2009-01-14 15:52:39 EST
If repoquery supported --disableexcludes, that would solve the issue perfectly.

Note You need to log in before you can comment on or make changes to this bug.