Bug 480077 - RFE: make user remove smartcard on screen lock or logout
RFE: make user remove smartcard on screen lock or logout
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 17:27 EST by jared jennings
Modified: 2014-06-09 10:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jjennings: needinfo-


Attachments (Terms of Use)

  None (edit)
Description jared jennings 2009-01-14 17:27:10 EST
Description of problem:

When users use smartcards to log in, they frequently forget to take them back out when locking the screen or logging out. Remind them, perhaps by playing a sound, or showing a message, or even refusing to complete the (user-requested) screen lock or logout until the smartcard is removed.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-8.el5
gnome-session-2.16.0-6.el5

Steps to Reproduce:
1. Log in with a smartcard.
2. Lock the screen.
3. Walk away.

Actual results:
The screen is locked and I am gone; an interloper only has to type a smart card PIN to unlock it. Security is degraded.

Expected results:
A reminder happens, I take the smartcard with me, the screen locks, and an interloper has to forcibly obtain my smartcard from my person, get back to my computer AND type a PIN to unlock my screen. Security is upheld.
Comment 1 RHEL Product and Program Management 2014-03-07 08:57:46 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:25:56 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.