Bug 480083 - No 8139too or 8139cp modules on boot.iso: can't do network installs with KVM
No 8139too or 8139cp modules on boot.iso: can't do network installs with KVM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 18:15 EST by James Wilkinson
Modified: 2009-01-18 15:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-18 15:24:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Wilkinson 2009-01-14 18:15:18 EST
Hi there.

My analysis:
It looks like boot.iso doesn't have all the network modules that the parent kernel RPM has. In particular, it seems like it doesn't have any drivers for a Realtek 8139 network card. Besides being popular in real life, this is what KVM and virt-manager emulate. This means that you can't use boot.iso to do a network install of Rawhide on a virt-manager guest.

Problem description:
I'm attempting to install Rawhide in a fully-virtualised machine using kvm and virt-manager. The host OS is a fully-updated Fedora 10. The guest OS boots, offers to check the media, enters X, displays the F10 splash screen, and then comes up with this error message:

Network Install Required

Your installation source is set to a network location, but no network devices were found on your system. To avoid a network installation, boot with the full DVD, full CD set, or do not pass a repo= parameter that specifies a network device.

The only option is "Exit Installer".

If I Ctrl-Alt-F2 to the shell, I get
lspci includes 
00:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139
C+ (rev 20)
lsmod | grep 8139 returns nothing

If I cd to 
/lib/modules/2.6.29-0.35.rc1.git4.fc11.x86_64/kernel/drivers/net
there are 35(gzipped) modules directly in that directory, by my counting, and no 8139 modules. If I download the kernel RPM separately, there are 70 ungzipped modules directly in the same directory.

Both host and guest are (Intel) x86_64.

Version-Release number of selected components (if applicable):
boot.iso as of 14-Jan-2009 07:53
kernel-2.6.29-0.35.rc1.git4.fc11.x86_64.rpm
Comment 1 Ronald Warsow 2009-01-15 04:39:43 EST
same here (since weeks)

no LAN Network offered during install in an KVM/native installation. 

in native installation WLAN network is only offered as eth0, but without firmware for Prism54/p45. Feeding this firmware via usb stick was without success so far.

Today I see the above described message.
Comment 2 Chris Lumens 2009-01-16 16:27:01 EST
Yes, a lot of network drivers are missing right now.  Jeremy just committed a fix for this earlier today, so they should show up in Rawhide once we do a new build of anaconda.
Comment 3 Ronald Warsow 2009-01-16 18:42:56 EST
thx. I will stay tuned !
Comment 4 Ronald Warsow 2009-01-17 20:40:20 EST
seems to be fixed, thx.
Comment 5 Mark McLoughlin 2009-01-18 15:24:01 EST
Thanks for verifying

Note You need to log in before you can comment on or make changes to this bug.