Bug 480108 - Update libuninameslist to 20080409
Update libuninameslist to 20080409
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libuninameslist (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roozbeh Pournader
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 22:42 EST by Roozbeh Pournader
Modified: 2009-01-16 00:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 18:23:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roozbeh Pournader 2009-01-14 22:42:08 EST
Apparently the new version of libuninameslist, 20080409, supports Unicode 5.1, which is quite useful for me, since the list is used in fontforge to display names for glyphs...

I can try to update the package myself. I just asked for commit access.
Comment 1 Kevin Fenzi 2009-01-14 22:50:58 EST
Sounds good... in rawhide feel free. 

For F-10 we should discuss and do at the same time as fontforge...
Comment 2 Roozbeh Pournader 2009-01-14 23:41:40 EST
Thanks. I was thinking of updating the versioning scheme of libuninameslist to reflect that of fontforge too: upstream is the same guy, he uses 8-digit dates for both, but we are using 0.0-8.20080409 for libuninameslist vs 20081215-2.fc11 for for fontforge. May I change the versioning scheme too?
Comment 3 Kevin Fenzi 2009-01-14 23:57:45 EST
I would think that would work fine... 20080409-1 is newer than 0.0-8.20080409, so there shouldnt be a problem. 

the 0.0 thing seems like the package was being treated as a prerelease or postrelease package, but in fact the date is the release version. ;)
Comment 4 Roozbeh Pournader 2009-01-15 18:23:10 EST
Update built for rawhide. For F-10, I'll wait until we figure out what to do with fontforge.
Comment 5 Kevin Fenzi 2009-01-16 00:13:04 EST
Should we rebuild fontforge against this version as well (in rawhide), 
and/or possibly update fontforge to the newest upstream (in rawhide)?

I guess we can discuss on the fonts list and/or irc...

Note You need to log in before you can comment on or make changes to this bug.