Bug 480121 - [oowriter] failed to export XHTML file
[oowriter] failed to export XHTML file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 03:42 EST by Cao, Chen
Modified: 2009-01-29 18:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:10:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the screenshots of oowriter failure to exoport xhtml (2.02 MB, application/x-gzip)
2009-01-16 03:01 EST, Cao, Chen
no flags Details
kernel version (225.42 KB, image/png)
2009-01-16 03:07 EST, Cao, Chen
no flags Details
OOo version (245.60 KB, image/png)
2009-01-16 03:08 EST, Cao, Chen
no flags Details
I have write permission (162.60 KB, image/png)
2009-01-16 03:09 EST, Cao, Chen
no flags Details
type the name and choose the format to export 1 (210.76 KB, image/png)
2009-01-16 03:11 EST, Cao, Chen
no flags Details
type the name and choose the format to export 2 (216.06 KB, image/png)
2009-01-16 03:11 EST, Cao, Chen
no flags Details
type the name and choose the format to export 3 (221.02 KB, image/png)
2009-01-16 03:12 EST, Cao, Chen
no flags Details
type the name and choose the format to export 4 (222.10 KB, image/png)
2009-01-16 03:13 EST, Cao, Chen
no flags Details
type the name and choose the format to export 5 (222.50 KB, image/png)
2009-01-16 03:13 EST, Cao, Chen
no flags Details
type the name and choose the format to export 6 (222.22 KB, image/png)
2009-01-16 03:14 EST, Cao, Chen
no flags Details
the error message. (186.88 KB, image/png)
2009-01-16 03:15 EST, Cao, Chen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98137 None None None Never

  None (edit)
Description Cao, Chen 2009-01-15 03:42:24 EST
Description of problem:
oowriter cannot export XHTML(.html, .xhtml) file.


Version-Release number of selected component (if applicable):
OpenOffice.org 3.0.0-9-10.fc10


How reproducible:
100% reproducible.


Steps to Reproduce:
1. launch OOo, and on the default menu, 'File -> New -> Text Document'
2. click 'File -> export...'
3. choose exporting file type to 'XHTML(.html, .xhtml)', type a 'Name'.
4. click 'Save'.
  
Actual results:
failed to save the XHTML file with message: 
'Error saving the document sampleFileName:
Write Error.
the file could not be writen.'


Expected results:
save the file successfully.


Additional info:
N/A
Comment 1 David Tardon 2009-01-15 04:22:46 EST
I installed openoffice.org-writer2xhtml and tried the export (XHTML 1.0 strict (.html)), without any error. Version of openoffice.org is 3.0.1-15.1.fc10 .

You reported F-10 version of openoffice.org, but set Version to rawhide. Which version of Fedora are you using?

From your results I would say you don't have write permission to selected directory or already existing file.
Comment 2 Cao, Chen 2009-01-15 04:44:06 EST
(In reply to comment #1)
> I installed openoffice.org-writer2xhtml and tried the export (XHTML 1.0 strict
> (.html)), without any error. Version of openoffice.org is 3.0.1-15.1.fc10 .
> 
> You reported F-10 version of openoffice.org, but set Version to rawhide. Which
> version of Fedora are you using?
> 
> From your results I would say you don't have write permission to selected
> directory or already existing file.

I installed F10 (kernel 2.6.27.9-159.fc10.i686).
--------------
[root@dhcp-xx-xx-xx HOME]# yum install openoffice.org-writer2xhtml
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package openoffice.org-writer2xhtml-0.5.0.2-2.fc10.i386 already installed and latest version
Nothing to do
-------------------

and I'm sure I have write permission to the directory and 
there is no existing file.

It's my fault to set it to 'rawhide'.
Comment 3 Cao, Chen 2009-01-16 03:01:04 EST
Created attachment 329172 [details]
the screenshots of oowriter failure to exoport xhtml 

what I did to trigger the error.
Comment 4 Cao, Chen 2009-01-16 03:03:14 EST
(In reply to comment #1)
> I installed openoffice.org-writer2xhtml and tried the export (XHTML 1.0 strict
> (.html)), without any error. Version of openoffice.org is 3.0.1-15.1.fc10 .
> 
> You reported F-10 version of openoffice.org, but set Version to rawhide. Which
> version of Fedora are you using?
> 
> From your results I would say you don't have write permission to selected
> directory or already existing file.


I cannot update OOo to rawhide because of yum problem.

But I still have this problem, even I have updated my OOo to 
3.0.1-15.1.fc10, 
and with openoffice.org-writer2xhtml-0.5.0.2-2.fc10.i386 installed.

the attachment is the screenshots.

besides, the problem still exists, as I run oowriter as root.
Comment 5 Cao, Chen 2009-01-16 03:07:55 EST
Created attachment 329173 [details]
kernel version
Comment 6 Cao, Chen 2009-01-16 03:08:35 EST
Created attachment 329174 [details]
OOo version
Comment 7 Cao, Chen 2009-01-16 03:09:34 EST
Created attachment 329175 [details]
I have write permission
Comment 8 Cao, Chen 2009-01-16 03:11:12 EST
Created attachment 329176 [details]
type the name and choose the format to export 1
Comment 9 Cao, Chen 2009-01-16 03:11:44 EST
Created attachment 329177 [details]
type the name and choose the format to export 2
Comment 10 Cao, Chen 2009-01-16 03:12:29 EST
Created attachment 329178 [details]
type the name and choose the format to export 3
Comment 11 Cao, Chen 2009-01-16 03:13:23 EST
Created attachment 329179 [details]
type the name and choose the format to export 4
Comment 12 Cao, Chen 2009-01-16 03:13:55 EST
Created attachment 329180 [details]
type the name and choose the format to export 5
Comment 13 Cao, Chen 2009-01-16 03:14:27 EST
Created attachment 329181 [details]
type the name and choose the format to export 6
Comment 14 Cao, Chen 2009-01-16 03:15:07 EST
Created attachment 329182 [details]
the error message.
Comment 15 David Tardon 2009-01-16 04:00:33 EST
Ah, I see now... Two redeclared variables in /usr/lib64/openoffice.org/basis3.0/share/xslt/export/xhtml/body.xsl (openoffice.org-xsltfilter).
Comment 16 David Tardon 2009-01-16 04:13:12 EST
dtardon->kcao: When you report versions of software and such stuff, you should always use pure text, i.e. terminal output of "uname -a", "rpm -qi openoffice.org-core", etc. Specifically for openoffice.org, the numbers it reports in about dialog are of no importance to us; what we need is version of appropriate RPM. 

writer2xhtml is yet another exporter to XHTML; it's "File format" lines in the export dialog contains "XHTML 1.0 strict" and "XHTML 1.1 ..."
Comment 17 David Tardon 2009-01-16 06:56:32 EST
Will be in 3.0.1-15.2 .
Comment 18 Fedora Update System 2009-01-29 18:10:09 EST
openoffice.org-3.0.1-15.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.