This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 480122 - [ooimpress] failed to hide slides in a certain condition
[ooimpress] failed to hide slides in a certain condition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 04:05 EST by Cao, Chen
Modified: 2009-01-15 10:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 10:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98112 None None None Never

  None (edit)
Description Cao, Chen 2009-01-15 04:05:29 EST
Description of problem:
start with the slide which is set to hidden, the slide and the hidden ones 
following it are all shown up.


Version-Release number of selected component (if applicable):
OpenOffice.org 3.0.0-9-10.fc10


How reproducible:
100% reproducible.


Steps to Reproduce:
1. create a new .odp with 5 slides.
2. mark the 1st, 2nd, 5th slide by right-click the slide in the 'Slides Pane',
and choose 'Hide slide' in the popup(context) menu.
3. select the 1st slide, and click 'Slide Show -> Slide Show' on the 
default menu (or simply press F5).



Actual results:
all the slides, except the 5th one, show up.


Expected results:
the slides marked as 'Hidden' should not show up, 
or at least, the 2nd slide should not show up.


Additional info:
N/A
Comment 1 Caolan McNamara 2009-01-15 10:44:06 EST
Hmm, rats, see upstream bug for some details.

But here's how it works:

By default in impress F5 means to "show slideshow from current slide", while in e.g. powerpoint "shift + F5" means to "show slideshow from current slide". In powerpoint and impress, this means to show the current slide even if it is hidden. And in both powerpoint and impress if the current slide was "hidden" then all the following slides are shown, whether hidden or non-hidden, until we return to a non-hidden slide.

In powerpoint however "F5" means to "show slideshow from start", and not "show slideshow from slide number 1", so the hidden slides can be skipped in powerpoint, but OOo doesn't have the same sort of thing.

So what we have here isn't actually broken, there isn't a bug. There is an argument for introducing a new feature of "start slideshow from beginning" and changing our config option for "start at slide 1", to instead use that new feature, binding it to e.g. F-5 and changing the current "start slideshow from current slide" to a new binding, e.g. shift-F5, or some other set of bindings. 

Lets call this notabug, as it is correctly following the current rules, even if those rules are a little unfortunate

Note You need to log in before you can comment on or make changes to this bug.