Bug 480154 - Upgrade mysql-connector-java from 3.1.12 to 5.1.7
Upgrade mysql-connector-java from 3.1.12 to 5.1.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql-connector-java (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
: 433653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 08:12 EST by Oliver Falk
Modified: 2009-09-15 03:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.1.8-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 03:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2009-01-15 08:12:17 EST
Description of problem:
Current mysql-connector-java is stuck at version 3.1, please upgrade.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
yum install mysql-connector-java

Take a look at http://dev.mysql.com/downloads/connector/j/. There's already version 5.1(.7).

Please note, that this version requires Java 1.4 or 1.5 to compile the 'old' JDBC connector, as well as Java 1.6 for the new JDBC 4.0.

I've managed to build it on F9 with java-1.6.0-sun (openjdk also works!) and java-1.5.0-gcj. alternatives for java/javac both set to gcj and the following properties added to ant:
-Dcom.mysql.jdbc.java6.rtjar=/usr/lib/jvm/java-1.6.0/jre/lib/rt.jar -Dcom.mysql.jdbc.java6.javac=/usr/lib/jvm/java-1.6.0/bin/javac

This was just a workaround to get it build at my machine... The final solution is for sure different :-)
Comment 1 Frank Häfemeier 2009-05-04 17:28:44 EDT
I vote for it!
Comment 2 Milos Jakubicek 2009-05-13 19:33:58 EDT
*** Bug 433653 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2009-06-09 06:44:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Goode 2009-07-15 09:27:52 EDT
Any update?

This is a request for a response, as given by https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers
Comment 5 Milos Jakubicek 2009-07-19 04:01:46 EDT
This still depends on the availability of jboss-common-jdbc-wrapper.jar which should be provided by jbossweb2, see the review bug 471915.
Comment 6 Milos Jakubicek 2009-08-25 22:00:05 EDT
OK, there was enough waiting on jbossweb2, I wiped out the jboss integration from mysql-connector-java-5.1.8. It is build in rawhide, updates-testing for F10/F11 will be coming soon.
Comment 7 Fedora Update System 2009-08-25 22:20:00 EDT
mysql-connector-java-5.1.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mysql-connector-java-5.1.8-1.fc11
Comment 8 Fedora Update System 2009-08-25 22:21:02 EDT
mysql-connector-java-5.1.8-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/mysql-connector-java-5.1.8-1.fc10
Comment 9 Fedora Update System 2009-08-26 22:14:30 EDT
mysql-connector-java-5.1.8-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql-connector-java'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9029
Comment 10 Fedora Update System 2009-08-26 22:16:34 EDT
mysql-connector-java-5.1.8-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql-connector-java'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9032
Comment 11 Fedora Update System 2009-09-15 03:34:08 EDT
mysql-connector-java-5.1.8-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-09-15 03:55:18 EDT
mysql-connector-java-5.1.8-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.