Bug 480213 - pungi initrd anaconda failed to boot
pungi initrd anaconda failed to boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 13:27 EST by xxartemisxx
Modified: 2013-01-10 00:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 06:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart (978 bytes, application/octet-stream)
2009-01-15 13:27 EST, xxartemisxx
no flags Details
pungi log (1.01 MB, text/plain)
2009-01-16 02:52 EST, xxartemisxx
no flags Details
kernel (1.99 MB, application/octet-stream)
2009-01-21 02:19 EST, xxartemisxx
no flags Details
initrd.img (9.15 MB, application/octet-stream)
2009-01-21 02:27 EST, xxartemisxx
no flags Details

  None (edit)
Description xxartemisxx 2009-01-15 13:27:05 EST
Created attachment 329121 [details]
kickstart

Description of problem:

Hi,
I'm creating a DVD with pungi.
This DVD doesn't boot.


failed to execute /init
kernel panic - not syncing : no init found. try passing init= option to kernel.




pungi command:
pungi -c /dir/conf.ks --destdir=/dir/test --name=test --vers=1 --nosource --nosplitmedia --force

I try with a different initrd.img in isolinux and anaconda run. The problem look like coming from isolinux/initrd.img from buildinstall of anaconda.

any idea ?
thanks 

Version-Release number of selected component (if applicable):
on fedora 9 : 2.6.27.9-73.fc9.i686
pungi: 1.2.18.1
anaconda: 11.4.0.83-1.i386

How reproducible:
always


Steps to Reproduce:
1.
create a small kickstart

2.
______________________________________________________________________
pungi -c /dir/conf.ks --destdir=/dir/test --name=test --vers=1 --nosource --nosplitmedia --force
______________________________________________________________________
3.
  boot the dvd
Actual results:
failed to execute /init
kernel panic - not syncing : no init found. try passing init= option to kernel.


Expected results:
DVD boot

Additional info:
was working before update.
Comment 1 Jesse Keating 2009-01-15 19:19:21 EST
Can you attach the log file from this compose?  It shoudl be in /d/r/test/logs/
Comment 2 xxartemisxx 2009-01-16 02:52:33 EST
Created attachment 329168 [details]
pungi log
Comment 3 xxartemisxx 2009-01-16 02:58:26 EST
I was running this kickstart in september and it run perfectly.
Now i need to update the iso.
So i create a server from scratch with:
"yum update -y && yum install pungi && reboot"

And now the created iso with the same kickstart doesn't boot ....

did i miss something ?

thanks,
Comment 4 Jesse Keating 2009-01-20 19:16:40 EST
Hrm, I don't see anything relevant in the logs.  Can you attach the kernel and initrd.img that were generated?
Comment 5 xxartemisxx 2009-01-21 02:19:28 EST
Created attachment 329557 [details]
kernel
Comment 6 xxartemisxx 2009-01-21 02:27:10 EST
Created attachment 329558 [details]
initrd.img
Comment 7 xxartemisxx 2009-01-21 02:34:27 EST
I change the initrd.img with my old initrd.img from the dvd i did in september and it didn't kernel panic. The install stop with an incorrect installer.

Is this initrd.img malformed ? How do you check the initrd ?

thks,
Comment 8 xxartemisxx 2009-02-03 09:11:12 EST
any news ?
Comment 9 Jesse Keating 2009-03-09 23:36:06 EDT
Hrm, I can't see anything causing problems.  See if there is anything installed if you do "yum install @buildsys-build" and if so, try your compose after that.
Comment 10 xxartemisxx 2009-03-16 06:10:37 EDT
hi,

Thanks it's working now. After the command sed was downloaded. maybe there is a missing dependency with "yum install pungi" ?


bye
Comment 11 Jesse Keating 2009-03-16 14:01:50 EDT
What was the error?  It could be one of the anaconda packages needs sed listed.
Comment 12 Daniel Drake 2012-02-06 14:49:39 EST
The problem in the above initramfs is that /sbin/init is not marked executable.


I also ran into something very similar (unbootable initramfs - can't execute init) respining CentOS 6.2 using pungi from F13. Just in case it helps anyone else: I ran into a different problem, where most important libraries (e.g. libc) were not included.

This is because /usr/lib/anaconda-runtime/mk-images uses file in instbin():
    iself="$(file $ROOT/$BIN | grep ELF)"

and file is not listed as a dependency of anaconda in F13. Installing it and rebuilding solves the issue.

I tried to check if current (F17) anaconda would suffer the same issue, but things seem to have moved around a lot, and grepping for 'file' is not that easy.

Note You need to log in before you can comment on or make changes to this bug.