Bug 480226 - Anaconda not setting UTC or timezone from kickstart file.
Anaconda not setting UTC or timezone from kickstart file.
Status: CLOSED DUPLICATE of bug 461526
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 14:26 EST by Keith Roberts
Modified: 2009-07-20 08:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 08:19:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart test file (1.86 KB, application/octet-stream)
2009-01-16 11:58 EST, Keith Roberts
no flags Details
Test Kickstart file (1.86 KB, text/plain)
2009-01-16 12:02 EST, Keith Roberts
no flags Details
Anaconda log file ( /var/log/anacoda.log ) (28.47 KB, text/plain)
2009-01-20 08:31 EST, Keith Roberts
no flags Details
Correct anaconda log file (27.69 KB, text/plain)
2009-01-20 10:36 EST, Keith Roberts
no flags Details

  None (edit)
Description Keith Roberts 2009-01-15 14:26:02 EST
Description of problem:

Anaconda does not set the UTC option or the timezone correctly when reading a kickstart file with ks=http://my-server/ks.cfg

Example kickstart file:

# Perform an installation from CD-ROM or DVD, in text mode.
install
cdrom
text

# Installation uses interactive mode.
interactive

# Select language.
lang en_US.UTF-8

# Select keyboard.
keyboard uk

# Select timezone.
timezone --utc Europe/London
Comment 1 Radek Vykydal 2009-01-16 09:53:50 EST
Can you be more specific? I tested your example kickstart file
and it works for me. Your link to ks.cfg is broken. You can
attach the file to bugzilla.
Comment 2 Keith Roberts 2009-01-16 11:58:03 EST
Created attachment 329230 [details]
Kickstart test file

Attachment as requested. The URL was just an example of using the http protocol for getting the kickstart file :)
Comment 3 Keith Roberts 2009-01-16 12:02:28 EST
Created attachment 329231 [details]
Test Kickstart file

Uploaded the KS file with the correct filename extension.
Comment 4 Radek Vykydal 2009-01-19 10:03:25 EST
If you mean setting the timezone during install (i.e. for post install ks scripts), it doesn't work indeed, and I will mark this bug as duplicate of bug #461526, which I am going to work on.
After first boot, the timezone should be set correctly. If your issue is not that of bug #461526, please describe it here and attach log file /var/log/anaconda.log.
Comment 5 Keith Roberts 2009-01-19 16:08:58 EST
No, I mean setting the timezone directly form the kickstart file in the main part of the kickstart configuration, as per the 2nd attachment.

Would it have anything to do with me using the:

# Select language.
lang en_US.UTF-8

I don't know what the equivalent language code is to set the language to UK English?

There are other problems with this kickstart file as well.

The /etc/resolv.conf file is not populated with any DNS servers.

I guess each issue is best  reported as a seperate bug?
Comment 6 Radek Vykydal 2009-01-20 04:45:18 EST
Yes, I meant setting the timezone with kickstart file too
in comment #4.
My question was if your issue (concerning timezone
setting, please report another issues as separate bugs)
is the same as the bug #461526 (comment #3, and comment #4),
which, in your case, would be that the timezone used during
install is not Europe/London.
Comment 7 Keith Roberts 2009-01-20 08:22:44 EST
Yes, bug #461526 (comment #3, and comment #4) does seem to be very similar to my report. I also attach the /var/log/anaconda.log file. Will open new bug reports for other issues with anaconda and K/S files :)
Comment 8 Keith Roberts 2009-01-20 08:31:56 EST
Created attachment 329460 [details]
Anaconda log file ( /var/log/anacoda.log )
Comment 9 Keith Roberts 2009-01-20 10:24:45 EST
Comment on attachment 329460 [details]
Anaconda log file ( /var/log/anacoda.log )

Log file from wrong machine !
Comment 10 Keith Roberts 2009-01-20 10:36:25 EST
Created attachment 329473 [details]
Correct anaconda log file
Comment 11 Radek Vykydal 2009-07-20 08:19:06 EDT
Closing as duplicate of bug #461526 per comment #7.

*** This bug has been marked as a duplicate of bug 461526 ***

Note You need to log in before you can comment on or make changes to this bug.