Bug 480256 - gpk-update-viewer should tell me how many MB of data will be downloaded for updates
gpk-update-viewer should tell me how many MB of data will be downloaded for u...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 19:29 EST by Daniel Berrange
Modified: 2009-04-15 12:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 12:39:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-01-15 19:29:33 EST
Description of problem:
The update icon indicates that new updates are available for my system, so select 'Show updates' to see what's pending. 

This launches 'gpk-update-viewer' telling me I've 40 packages to get.

If I'm on a slow (or very expensive) data link, the number of packages available for update is fairly irrelevant. What I most care about is how many MB of data are going to be downloaded by applying the updates. This information is not shown in the summary, nor available if I select 'Review' to see per-package details.

In the summary view I'd like to see it show

  * 5 security updates (50 MB)
  * 38 bug fix updates (1.5 GB)
  * 1 update (5 MB)


And when it is in the progress of downloading the updates it should show progress in terms of data downloaded, since that's the most time relevant metric for that operation - a single openoffice RPM dwarfs size of 30 other updates, so per-package progress info is again not very helpful.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.12-3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 E Bordin 2009-01-16 04:44:49 EST
I agree, I would like to see this feature as well. Furthermore, information on the current download speed and possibly an estimation of remaining time would be very useful. A pause button could be another addition (though I believe in its current state the updater does make use of any previously downloaded files).
Comment 2 JanS 2009-03-10 15:13:12 EDT
I see this problem too.

It would be very nice to see it fixed. For me beeing on slow or expensive connection, usually ends up with closing gpk-update-viewer and running yum update manually. Since yum have very nice feedback on data to be downloaded as well as information during downloading (in percents and megabytes) added recently.
Also yum takes into account packages allready in /var/cache/yum. For example if someone interruped previous update process, some packages have been aquired and now we substract size of them from total download size.
Comment 3 JanS 2009-03-10 15:38:54 EDT
Bug 479514 should have been marked as a duplicate of this bug.
Comment 4 Richard Hughes 2009-03-11 06:11:07 EDT
Try gpk-update-viewer2 in rawhide. It tells you how many Mb you need to download.

Note You need to log in before you can comment on or make changes to this bug.