Bug 480277 - Unable to edit RAW print queue properties
Unable to edit RAW print queue properties
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 00:58 EST by Christopher Tubbs
Modified: 2009-01-21 16:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2009-01-16 00:58:38 EST
Description of problem:
I've added an HP USB printer to cups, which works great with the new interface. I've also added a RAW print queue for the same printer, so I can print via ipp:// from my Windows boxes with the native HP drivers for Windows. The problem is that after I have added the RAW queue, I am unable to make any changes to it whatsoever (like editing error policy or any of the other normal options that one is allowed to edit). The window simply does not appear when I right click the RAW queue and click properties (not even the. The hpijs queue seems to work fine. I AM able to print to the RAW queue, but occasionally there are errors, and it seems I need to re-enable the printer after reboots.

Version-Release number of selected component (if applicable):
system-config-printer-1.0.12-2.fc10.i386
hpijs-2.8.7-3.fc10.i386
hplip-2.8.7-3.fc10.i386
cups-1.3.9-6.fc10.i386
hal-cups-utils-0.6.17-4.fc10.i386
cupsddk-drivers-1.2.3-5.fc10.i386
libgnomecups-0.2.3-4.fc10.i386
cups-libs-1.3.9-6.fc10.i386
gutenprint-5.0.2-3.fc10.i386

How reproducible:
100% on the inability to open the properties window for RAW Queue
Unsure on reproducability of requiring re-enable on reboot (I suspect this is because of error-policy: stop-printer)

Steps to Reproduce:
1. Open system-config-printer
2. Install RAW print queue via add printer dialog.
3. Once printer is created and icon appears, attempt to edit it's properties.
4. (If successful in opening properties window, try again, but add a non-RAW queue for the printer first).
  
Actual results:
Nothing happens.

Expected results:
Dialog for printer properties should appear (after root password is entered).

Additional info:
kernel-2.6.27.9-159.fc10.i686
Comment 1 Fedora Update System 2009-01-16 18:45:36 EST
system-config-printer-1.0.13-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11136
Comment 2 Fedora Update System 2009-01-16 18:49:05 EST
system-config-printer-1.0.13-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11189
Comment 3 Fedora Update System 2009-01-21 16:29:54 EST
system-config-printer-1.0.13-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2009-01-21 16:38:31 EST
system-config-printer-1.0.13-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.