Bug 480325 - Impossible to add encryption key to kmail
Impossible to add encryption key to kmail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 09:21 EST by Anne
Modified: 2009-02-19 08:29 EST (History)
6 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 169563 None None None Never

  None (edit)
Description Anne 2009-01-16 09:21:56 EST
Description of problem:
On opening the Cryptography tab, the signing key is displayed correctly, but it is impossible to add the encryption key.

Version-Release number of selected component (if applicable):
Seen in all versions under Fedora 9 and Fedora 10.  Current version 1.10.4

How reproducible:
Consistent

Steps to Reproduce:
1.Check that gpg commands work from the command line
2.Open configuration options to cryptography tab
3.Add signing key and encryption key
  
Actual results:
The key is not offered from the keyring for encryption.  Instead you get a 'Fetching Keys notice' and a busy bar running back and forth endlessly.

Expected results:
The key should be selectable from the existing keyring.

Additional info:
KMail has been deliberately killed with a killall -6, but the trace only showed that the key selection window was open.  1.10.3 under Mandriva works - this seems to be Fedora-specific.  Thunderbird + Enigmail works (Fedora 10) without a problem.
Comment 1 Rex Dieter 2009-01-16 09:33:47 EST
rpm -q kdepim gpgme gnupg2
please.

If possible, since you mentioned this works on Mandriva, if you could determine the versions of those same packages there for comparison, it would be greatly appreciated.

Even though you suspect this to be fedora-specific, my gut tells me not, we don't modify/patch this stack of packages, so this bug is likely upstreamable to bugs.kde.org.
Comment 2 Rex Dieter 2009-01-16 09:39:38 EST
And to be clear, are you using kmail under KDE or other DE?  

If not KDE, the lack of auto gpg-agent startup script support there may have something to do with it.
Comment 3 Anne 2009-01-16 10:01:57 EST
In both cases I'm running under KDE4.  The Mandriva version is kmail-4.1.3-2.1mdv2009.0.  The F10 version appears to be kdepim-6:4.1.4-1.fc10 (i386) although as I said, I have had this problem throughout in F9 and F10.  Another box is running F9 with kdepim-3.5.10-2.fc9.i386.  The symptoms are the same.
Comment 4 Rex Dieter 2009-01-16 10:10:07 EST
and
rpm -q gnupg2 gpgme
please
Comment 5 Anne 2009-01-16 10:57:40 EST
Mandriva - gnupg2-2.0.9-3mdv2009.0, libgpgme11-1.1.6-2mdv2009.0

Fedora10 - gnupg-1.4.9-4.fc10.i386, gpgme-1.1.7-1.fc10.i386

Fedora9 -  gnupg-1.4.9-1.fc9.i386, gpgme-1.1.6-3.fc9.i386
Comment 6 Anne 2009-01-23 14:27:09 EST
I have today discovered that this is not a Fedora issue as such.  My Mandriva laptop has been signing and encrypting with identities that were already linked to a gpg key.  However, if I try to set a new Identity linked to my keys I see the same problem as in Fedora.  I conclude, therefore, that Rex is correct, and this is an upstream issue.
Comment 7 Anne 2009-01-23 14:56:27 EST
On speaking to the maintainer I was told that this sounds like kde bug 169563.
Comment 8 Rex Dieter 2009-01-23 15:00:25 EST
cool, when kdepim-4.2.0 lands, please let us know if problems persist.
Comment 9 Fedora Update System 2009-02-04 21:26:56 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 10 Fedora Update System 2009-02-06 00:24:13 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 11 Fedora Update System 2009-02-07 17:21:01 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 12 Anne 2009-02-19 08:29:55 EST
For archive purposes:

I had a keyring that had grown over several years.  Something in the keyring was not acceptable to either Fedora9 or Fedora10 installations.  It's rather strange that the same keyring did work on a Mandriva and a CentOS installation, so it is likely that the newer versions are tighter in requirements.

If anyone is reading this due to a similar problem, I'd recommend moving the keyring aside and starting a clean one for testing.  This worked for me, and I can simply re-import keys as required.

Note You need to log in before you can comment on or make changes to this bug.