Bug 480337 - kernel-2.6.29-0.38.rc1.git4.fc11.x86_64 fails to prompt for encrypted partition password, fails to boot
kernel-2.6.29-0.38.rc1.git4.fc11.x86_64 fails to prompt for encrypted partiti...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 09:56 EST by Tom London
Modified: 2009-01-17 12:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-17 12:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of screen hanging on boot...... This is just about where passphase would be requested..... (230.75 KB, image/jpeg)
2009-01-16 09:56 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-01-16 09:56:09 EST
Created attachment 329210 [details]
Photo of screen hanging on boot......  This is just about where passphase would be requested.....

Description of problem:
Booting kernel-2.6.29-0.38.rc1.git4.fc11.x86_64 hangs.

If booting with plymouth, it fails to prompt for password to unlock encrypted partitions, and eventually hangs.

If booting without plymouth (e.g., without "rhgb quiet"), it appears to hang just after probing for keyboard, and just about when it would prompt for passphrase. 

I attach "photo" of screen when it hangs.

kernel-2.6.29-0.35.rc1.git4.fc11.x86_64 continues to boot just fine.

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.38.rc1.git4.fc11.x86_64

How reproducible:
Every time.  (Every install and every time)

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-01-16 09:57:22 EST
One addition detail:  ctrl-alt-delete does cause reboot.  Get 2 or 3 messages about shutting down.
Comment 2 Jerry Amundson 2009-01-16 12:04:56 EST
Same here. I have no encrypted partitions.
Comment 3 Tom London 2009-01-16 14:43:07 EST
Should have added system detail:  

Thinkpad X200, fully rawhide.
Comment 4 Tom London 2009-01-16 17:07:05 EST
My system boots OK with kernel-2.6.29-0.40.rc1.git6.fc11.x86_64, encrypted partitions and all.....
Comment 5 Tom London 2009-01-17 12:15:44 EST
Both kernel-2.6.29-0.40.rc1.git6.fc11.x86_64 and kernel-2.6.29-0.41.rc2.fc11.x86_64 boot fine on my system.

I'm guessing that was just a "DOA" build (at least for my system).

Closing.

Jerry, reopen if your system still doesn't boot.

Note You need to log in before you can comment on or make changes to this bug.