Bug 480341 - /etc/init.d/rhn-proxy should be in /etc/rc.d/init.d/rhn-proxy
/etc/init.d/rhn-proxy should be in /etc/rc.d/init.d/rhn-proxy
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Proxy Server (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-01-16 10:17 EST by Jan Pazdziora
Modified: 2009-09-17 03:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-01-16 10:17:25 EST
Description of problem:

Fedora Packaging says on their page
   https://fedoraproject.org/wiki/Packaging/SysVInitScript
   Packages with SysV-style initscripts must put any them into
   /etc/rc.d/init.d. A rpm macro exists for this directory, %_initrddir.

   In the past, some packages were putting files in /etc/init.d instead
   of /etc/rc.d/init.d. (/etc/init.d is a symlink to /etc/rc.d/init.d)

   This split made it more difficult to use yum install against the
   initscript filename and path. Since /etc/init.d is the symlink (and
   because the Filesystem Hierarchy Standard does not mandate a location),
   Fedora requires that all SysV-style initscripts must go into the full
   /etc/rc.d/init.d directory. 

The package spacewalk-proxy-tools states the location of rhn-proxy initscript is /etc/init.d/rhn-proxy.

Version-Release number of selected component (if applicable):

spacewalk-proxy-tools-0.4.5-1.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. rpm -ql spacewalk-proxy-tools | grep '/etc'
  
Actual results:

/etc/init.d/rhn-proxy

Expected results:

/etc/rc.d/init.d/rhn-proxy

Additional info:

Well, maybe the rhn-proxy should be gone from /etc/*/init.d altogether and moved to /usr/sbin, just like rhn-satellite was moved away from /etc.
Comment 1 Miroslav Suchý 2009-01-19 05:19:27 EST
Fixed in 487e805f549d3a3dc0022769958588848af09253
and in packages:
spacewalk-proxy-installer-0.5.1-1
spacewalk-proxy-0.5.1-1
Comment 2 Jesus M. Rodriguez 2009-04-14 10:12:19 EDT
Spacewalk 0.5 released.
Comment 3 Miroslav Suchý 2009-09-17 03:09:18 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.