Bug 480342 - No startup scripts should be in /etc/init.d, all should go to /etc/rc.d/init.d
No startup scripts should be in /etc/init.d, all should go to /etc/rc.d/init.d
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space07
  Show dependency treegraph
 
Reported: 2009-01-16 10:25 EST by Jan Pazdziora
Modified: 2009-12-07 07:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 07:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-01-16 10:25:41 EST
Description of problem:

Fedora Packaging says on their page
   https://fedoraproject.org/wiki/Packaging/SysVInitScript
   Packages with SysV-style initscripts must put any them into
   /etc/rc.d/init.d. A rpm macro exists for this directory, %_initrddir.

   In the past, some packages were putting files in /etc/init.d instead
   of /etc/rc.d/init.d. (/etc/init.d is a symlink to /etc/rc.d/init.d)

   This split made it more difficult to use yum install against the
   initscript filename and path. Since /etc/init.d is the symlink (and
   because the Filesystem Hierarchy Standard does not mandate a location),
   Fedora requires that all SysV-style initscripts must go into the full
   /etc/rc.d/init.d directory. 

The packages osad, osa-dispatcher, spacewalk-search and spacewalk-taskomatic put their initscripts to /etc/init.d.

Version-Release number of selected component (if applicable):

On server:

osa-dispatcher-5.9.2-1.el5
spacewalk-search-0.4.10-1.el5
spacewalk-taskomatic-0.4.16-1.el5

On client:

osad-5.9.2-1.el5

How reproducible:

Deterministic.

Steps to Reproduce:
1. rpm -ql osad osa-dispatcher spacewalk-search spacewalk-taskomatic | grep '/etc.*/init\.d/'
  
Actual results:

/etc/init.d/osad
/etc/init.d/osa-dispatcher
/etc/init.d/rhn-search
/etc/init.d/taskomatic

Expected results:

/etc/rc.d/init.d/osad
/etc/rc.d/init.d/osa-dispatcher
/etc/rc.d/init.d/rhn-search
/etc/rc.d/init.d/taskomatic

Additional info:
Comment 2 Jesus M. Rodriguez 2009-05-04 10:40:35 EDT
taskomatic fixed
Comment 3 Miroslav Suchý 2009-12-01 03:45:46 EST
rhn-search fixed in commit 2c121b5a170763fb86afa902159a59a1857bf2df
Comment 4 Miroslav Suchý 2009-12-07 07:02:42 EST
Spacewalk 0.7 released.

Note You need to log in before you can comment on or make changes to this bug.