Bug 480366 - Deletion of home directory by gnomad2
Deletion of home directory by gnomad2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomad2 (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 12:38 EST by Robert Kochis
Modified: 2009-01-29 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of gnomad2 (28.38 KB, image/png)
2009-01-16 12:38 EST, Robert Kochis
no flags Details

  None (edit)
Description Robert Kochis 2009-01-16 12:38:19 EST
Created attachment 329232 [details]
screenshot of gnomad2

Description of problem:
gnomad2 has flaw that causes home directory contents to be deleted.

Version-Release number of selected component (if applicable):
2.9.1

How reproducible:
I would imagine completely reproducable but I already lost 10 days of work.

Steps to Reproduce:
1.Open gnomad2
2.press CTRL-A to select all files
3.Right mouse click and select delete selected
  
Actual results:
Delete command traverses home directory and deletes all folders except defaults such as Videos, Downloads, etc.

Expected results:
Delete all music files selected

Additional info:
double period at top of list is the problem.
Comment 1 Linus Walleij 2009-01-16 20:11:36 EST
I can't replicate this, are you sure this appeared with gnomad 2.9.1
and not 2.9.0?

In 2.9.1 the bug was fixed in this commit:
http://gnomad2.cvs.sourceforge.net/viewvc/gnomad2/gnomad2/src/filesystem.c?r1=1.63&r2=1.64

As you can see from here it was tagged for 2.9.1:
http://gnomad2.cvs.sourceforge.net/viewvc/gnomad2/gnomad2/src/filesystem.c?view=log
Comment 2 Robert Kochis 2009-01-17 10:35:12 EST
Linus, 
As noted in the title bar of the attached screenshot, I am running 2.9.1

I retrieved this software through PackageKit and not a direct download from anywhere else.
Thank you, Bob
Comment 3 Linus Walleij 2009-01-18 04:30:46 EST
The problem is that I cannot replicate the erroneous behaviour here,
this is 2.9.2 on F10 so I don't have exactly the same environment
however.

I have:
* set up a dummy account from the user manager
* log in to that account
* start gnomad (2.9.2)
* enter "Music" folder
* select all files in the host view Ctrl+A (including "..")
* choose delete
* choose yes
* home dir does not get deleted

I'll push Gnomad 2.9.2 to F-9 updates and hope that solves the issue
then, OK?
Comment 4 Robert Kochis 2009-01-18 16:36:40 EST
Linus, 
Thank you.  I will test it completely as soon as I see the update come across.  I will then let you know how I make out.  Bob
Comment 5 Fedora Update System 2009-01-19 17:06:48 EST
gnomad2-2.9.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gnomad2-2.9.3-1.fc9
Comment 6 Fedora Update System 2009-01-21 16:28:03 EST
gnomad2-2.9.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gnomad2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0742
Comment 7 Robert Kochis 2009-01-22 10:40:27 EST
I installed update 2.9.3 and same problem exists.  I started with a blank Music directory, copied a number of files from Creative Jukebox, went to left pane, pressed CTRL-A, right mouse, delete selected and entire home directory disappeared.

I am guessing that as long as the ellipse appears in the file list the delete command will traverse up the tree and delete everything.  

2.6.27.9-73.fc9.i686 kernel with Fedora 9.  

Thank you, Bob
Comment 8 Linus Walleij 2009-01-22 17:20:52 EST
After some struggling I could finally reproduce the problem.
The code avoids ".." and "." but not "/foo/Music/.." etc.

Stupid me. Working on a fix!
Comment 9 Robert Kochis 2009-01-23 09:28:53 EST
Linus, 
I upgraded my computer to F10 yesterday and verified that the entire home directory is NOT deleted, but the folder Music is deleted.  Definitely an improvement.

I still have my computer with F9 imaged with Clonezilla.  If you would like me to test anything under F9 please do not be afraid to ask.  Thanks for the utility my MP3 player tends to take a beating!

Bob
Comment 10 Fedora Update System 2009-01-23 21:42:24 EST
gnomad2-2.9.4-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update gnomad2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0930
Comment 11 Linus Walleij 2009-01-24 17:02:44 EST
I think this 2.9.4-1 release shall have the problem FINALLY fixed.
It should not delete the Music folder either, so please verify this
also...
Comment 12 Fedora Update System 2009-01-29 18:12:00 EST
gnomad2-2.9.4-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.