Bug 480392 - banshee 1.4.1 sometimes crashes
banshee 1.4.1 sometimes crashes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 15:01 EST by Lodegario Malpica
Modified: 2011-04-06 07:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace banshee-1 (37.05 KB, text/plain)
2009-01-16 15:01 EST, Lodegario Malpica
no flags Details

  None (edit)
Description Lodegario Malpica 2009-01-16 15:01:03 EST
Created attachment 329247 [details]
strace banshee-1

Description of problem:
I installed fedora 10 in 64 bits, I was looking for some good music media player rythmhbox has a very low volume and doesn't has equalizer, amarok 2 doesn't work in gnome and when you can do it to work it has also very low volume then I found banshee and it worked OK. After some fedora 10 updates it began to crash.

When you run it sometimes the window appears but you can do nothing, the window becomes gray and when you try to close it, fedora kill the process. If you try to re-open with good-luck it works.

When I run strace it has some problems with gcc and mono libs as you can see in the attachment

Version-Release number of selected component (if applicable):

banshee 1.4.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2009-01-23 05:05:59 EST
I've seen very similar behaviour.  Tried it just now with --debug and saw these warnings:

** (Banshee:4589): WARNING **: Symbol file /usr/lib64/mono/gac/Mono.Zeroconf/1.0.0.75__e60c4f4a95e1099e/Mono.Zeroconf.dll.mdb has incorrect version (expected 50.0, got 39)

** (Banshee:4589): WARNING **: Symbol file /usr/lib64/mono-zeroconf/Mono.Zeroconf.Providers.Avahi.dll.mdb has incorrect version (expected 50.0, got 39)

** (Banshee:4589): WARNING **: Symbol file /usr/lib64/mono-zeroconf/Mono.Zeroconf.Providers.Bonjour.dll.mdb has incorrect version (expected 50.0, got 39)

in case that's relevant.
Comment 2 Michel Alexandre Salim 2009-01-23 16:43:25 EST
The Zeroconf error is harmless, as far as I can tell -- see

http://www.mail-archive.com/mono-list@lists.ximian.com/msg26563.html

It appears to be harmless, but if that's bothersome, you can contact the mono-zeroconf and ndesk-dbus-glib maintainers. The packages have not been rebuilt since F-9 because there are no new release since then.

As to the intermittent crashes, are they fixed if you remove Banshee configuration files? rm -rf $HOME/.gconf/apps/banshee-1 and killall gconfd-2, and try starting Banshee again. It should not affect your music library, just the preferences.
Comment 3 Adam Huffman 2009-01-25 08:11:47 EST
Just tried that and the crash after startup still happened.

Oddly, if I do start from a terminal with --debug, it starts normally.  Perhaps it's a timing issue, and the slowdown from the debug output works around it?
Comment 4 Bug Zapper 2009-11-18 05:46:26 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-12-18 02:37:25 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.