Bug 480439 - RFE: Revisor should not require root access
RFE: Revisor should not require root access
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
10
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 05:35 EST by Joachim Frieben
Modified: 2009-01-31 20:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-31 20:35:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-01-17 05:35:13 EST
Description of problem:
When launching revisor, it immediately asks for the root password which suggests that it runs with full root authorization afterwards. This is probably unnecessary and should not be the case. I should be possible to create a spin as an ordinary user using globally writable directories/files or (better) carry out all necessary operations confined to the user's home directory.

Version-Release number of selected component (if applicable):
revisor-2.1.3-1.fc10

How reproducible:
Always.

Steps to Reproduce:
1. Launch revisor.
  
Actual results:
Revisor asks for root password.

Expected results:
Revisor creates GUI window immediately running with limited rights.

Additional info:
I do not see the need for running revisor as root. For creating RPM packages using 'rpm', this mode has long been deprecated. It is much better to set up the build directories locally in the user's home directory and create them as ordinary user with limited rights. As of F10, /usr/src/redhat/.. does not even exist anymore. Even when running 'rpm' as root, the build process happens in root's home directory. The same reasoning applies to revisor, at least in my eyes.
Comment 1 Fedora Admin XMLRPC Client 2009-01-31 19:05:59 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jeroen van Meeuwen 2009-01-31 20:35:59 EST
This is not a bug in the Revisor software, we do require root privileges to set up loop devices and so forth.

Note You need to log in before you can comment on or make changes to this bug.