Bug 480442 - liveusb-creator fails to launch from GNOME menu
liveusb-creator fails to launch from GNOME menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
10
noarch Linux
low Severity medium
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 06:56 EST by Joachim Frieben
Modified: 2009-07-20 15:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 15:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-01-17 06:56:09 EST
Description of problem:
When launched from GNOME menu "Applications > System Tools > liveusb-creator"
nothing happens. Only upon inspection of .xsession-errors. it becomes apparent that the former needs to be launched as root:

  "You must run this application as root"

Version-Release number of selected component (if applicable):
liveusb-creator-3.5-1.fc10.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Click GNOME menu item "Applications > System Tools > liveusb-creator".
  
Actual results:
None.

Expected results:
liveusb-creator GUI is launched.

Additional info:
- related tool revisor prompts user for root password and then proceeds.
- it should be possible to run liveusb-creator as ordinary user which
  is the recommended operation mode e.g. of 'rpmbuild' anyway.
Comment 1 Christopher Brown 2009-01-31 19:55:41 EST
It works for me on i686.  What happens when you launch from terminal?
Comment 2 Joachim Frieben 2009-02-01 05:58:23 EST
When launched from the shell, then the user is graphically prompted for the root password. After entering it, the GUI of liveusb-creator comes up.
Comment 3 Joachim Frieben 2009-02-01 06:04:03 EST
Hum, tried a second time, and now it returns:

  $ liveusb-creator 
  You must run this application as root

Strange indeed ..
Comment 4 Luke Macken 2009-02-09 12:02:46 EST
I cannot reproduce this issue.  When I run the liveusb-creator from the menu, and from the command-line, it prompts me for the root password.
Comment 5 Joachim Frieben 2009-02-16 16:01:31 EST
I have reinstalled F10 x86_64 from scratch [network method with active updates channel], and the behaviour ist just the same: "You must run this application as root" appears in .xsession-errors or in the shell respectively. The user only belongs to group "users" [GID 100].
Comment 6 Luke Macken 2009-03-08 21:27:42 EDT
Please try and reproduce this issue with v3.6+ of the liveusb-creator.  Thanks!
Comment 7 Joachim Frieben 2009-03-10 04:10:51 EDT
No change for liveusb-creator-3.6-1.fc10. However, I have nailed down the culprit which appears to be a cutomized PATH variable prepending /usr/sbin to $PATH:

  /usr/bin/liveusb-creator: OK
  /usr/sbin/liveusb-creator: "You must run this application as root"

I suppose this bug can hence be closed as "NOTABUG", can't it?

Note You need to log in before you can comment on or make changes to this bug.