Bug 480466 - [openoffice.org] Adapt to font package renamings
[openoffice.org] Adapt to font package renamings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11-new-font-naming
  Show dependency treegraph
 
Reported: 2009-01-17 07:44 EST by Nicolas Mailhot
Modified: 2009-01-20 05:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 05:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-01-17 07:44:28 EST
Notification of font package renamings
Comment 1 Nicolas Mailhot 2009-01-17 08:01:43 EST
FPC unexpectedly refused to ratify a proposal that put into writing our de-facto font package naming rules for the past years, and requested naming changes. As a result many font packages have been or will be renamed soon (including recently created packages)

We have detected your package depends on such a font package. Please change your dependencies accordingly.

See also
— http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_(FAQ)#fpc_renaminghttp://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_(2009-01-13)
— http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_(FAQ)#What_if_my_package_bundles_Bitstream_Vera.2C_Arev.2C_DejaVu_LGC_or_another_Bitstream_Vera_font_derivative.3F

To ease the transition and avoid breaking F11 Alpha DejaVu has already been renamed but still declares its old names for full via rpm Provides. Those provides will be removed for Fedora 11 beta, to ensure no remaining legacy deps remains in the distribution. In the meanwhile packages depending on DejaVu full won't break and can be adapted at your leasure.
Comment 2 Caolan McNamara 2009-01-18 17:51:48 EST
This issue seems to assume that I know what the issue is about. I don't know what the problem is and what the proposed solution in. I don't live and breathe the font situation de jour, all this issue says is "there is something about fonts, and there is a pile of links about it"
Comment 3 Nicolas Mailhot 2009-01-19 01:51:52 EST
Please take a look at the pile of links, they contain the info you ask for. If I repeated it here and in all the bugs that need it I'd only forget stuff, make mistakes, and waste everyone's time.

http://fedoraproject.org/wiki/Shipping_fonts_in_Fedora_(FAQ)#fpc_renaming_fix
Comment 4 Nicolas Mailhot 2009-01-19 01:56:32 EST
Drat. Added the right link in the wrong report.

In this issue you're just warned font packages you depend on have been/will be renamed shortly, so your package dependencies will break.

There is not much to do except changing your deps once that happens (dejavu has been renamed, liberation has in koji but has not hit rawhide yet, smc had been too, and you may depend on others yet)
Comment 5 Nicolas Mailhot 2009-01-19 02:02:14 EST
And just to be 100% clear I didn't ask for this latest renaming run, FPC forced it on us, I'm only the poor sod who gets to implement their decision and be yelled at, so if you're not happy complain at them not at me.
Comment 6 Caolan McNamara 2009-01-19 04:09:24 EST
So this is change font requires. Adapted to the ones I see at the moment.

Note You need to log in before you can comment on or make changes to this bug.