Bug 480504 - RTLD_DEEPBIND may crash pulseaudio
RTLD_DEEPBIND may crash pulseaudio
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 17:26 EST by Jan Kratochvil
Modified: 2009-01-26 20:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 20:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase for RTLD_DEEPBIND unrealted to xine-lib. (1009 bytes, application/octet-stream)
2009-01-17 17:26 EST, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2009-01-17 17:26:30 EST
Created attachment 329291 [details]
Testcase for RTLD_DEEPBIND unrealted to xine-lib.

Description of problem:
Filing here a Bug originally reported by Gregory Hosler.
xine-lib can crash in pulseaudio due to its (upstream fixed) Bug
http://www.pulseaudio.org/changeset/701384935446a5705cb77a9da2f896b086a392be
But this Bug would not occur if xine-lib would not use RTLD_DEEPBIND in its patch `xine-lib-1.1.1-deepbind-939.patch' (cannot find any Bug number 939).
http://cvs.fedora.redhat.com/viewvc/rpms/xine-lib/devel/xine-lib-1.1.1-deepbind-939.patch?revision=1.1
While I did not try xine-lib myself without this patch there are given no reasons in the .spec file for it.  Could be this patch removed?

This Bug occurs as RTLD_DEEPBIND makes the `environ' variable NULL.  Without RTLD_DEEPBIND such unusual (despite valid) state would not occur.

Version-Release number of selected component (if applicable):
xine-lib-1.1.16-1.1 (src)

Attaching a bit unrelated testcase (deepbind-environ) showing `environ' gets cleared due to RTLD_DEEPBIND.
Comment 1 Rex Dieter 2009-01-18 15:34:27 EST
Interesting.

I'm unfamiliar with the history too, but this seems to be it:
http://bugzilla.livna.org/show_bug.cgi?id=939
Comment 2 Kevin Kofler 2009-01-18 15:41:30 EST
Looks like the right fix there would be to get xine-lib-extras-freeworld to also use the system libfaad, if this isn't already done. Then we can get rid of that hack.
Comment 3 Rex Dieter 2009-01-18 16:07:09 EST
Yup, beat me to it.

Just committed changes doing just that (for rawhide/f11 anyway).  Provided the builds complete and nothing blows up, we'll consider doing so for other branches as well.
Comment 4 Jan Kratochvil 2009-01-18 16:13:44 EST
Nice it found a library duplicity, thanks.
Comment 5 Fedora Update System 2009-01-23 21:34:39 EST
xine-lib-1.1.16.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xine-lib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0884
Comment 6 Fedora Update System 2009-01-26 20:50:10 EST
xine-lib-1.1.16.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.